Bug 113534 - netatalk-1.6.4-1: cnid_open: dbenv->open of /var/spool/mac-printing/dj5550-photo/.AppleDB failed: Invalid argument
Summary: netatalk-1.6.4-1: cnid_open: dbenv->open of /var/spool/mac-printing/dj5550-ph...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: netatalk   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-14 23:57 UTC by Jonathan Kamens
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 22:39:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2004-01-14 23:57:40 UTC
When a client attempts to connect to afpd in netatalk-1.6.4-1, I get a
bunch of syslog messages like this and the access fails:

Jan 14 16:04:33 jik afpd[14326]: [cnid_open.c:338]: E:Default:
cnid_open: dbenv->open of
/var/spool/mac-printing/dj5550-photo/.AppleDB failed: Invalid argument

I suspect this has something to do with the fact that I'm using a
non-NPTL kernel.  See bug #112159.  If so, then I suppose this may be
a db4 bug (i.e., #112159) rather than a netatalk bug.

Comment 1 Charles Dostale 2004-01-29 16:49:54 UTC
This may be a permissions problem. I had a similar error message until
I made the permissions of the shared directory less restrictive.
netatalk needs to be able to create the .AppleDB directory and users
need to be able to write to files within the .AppleDB directory. This
occurs because 1.6.4 has cnid database enabled, 1.5.x did not. The
cnid db is a Good Thing, but for those used to configuring 1.5.x, the
permissions issue is perplexing.

Comment 2 Jonathan Kamens 2004-01-29 17:13:04 UTC
I am pretty certain this is not a permissions problem.  Netatalk has
the permissions it needs to write to .AppleDB.  As I said, I believe
it is a NPTL issue.


Comment 3 Charlie Bennett 2004-09-22 22:15:33 UTC
Marking this as a Fedora Core bug to be evaluated during Fedora Core
bug week.

Comment 4 Jason Vas Dias 2005-06-16 22:39:02 UTC
This bug not not occur with the latest netatalk-2.0.3-1 release in
rawhide, also available for FC5/4/3 from: 
http://people.redhat.com/~jvdias/netatalk


Note You need to log in before you can comment on or make changes to this bug.