Bug 1135546 - [abrt] virt-manager: g_socket_constructed(): python2.7 killed by SIGTRAP
Summary: [abrt] virt-manager: g_socket_constructed(): python2.7 killed by SIGTRAP
Keywords:
Status: CLOSED DUPLICATE of bug 1135808
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:83aaae1b591789477922b59ce80...
: 1049665 (view as bug list)
Depends On:
Blocks: F21FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-08-29 14:48 UTC by Stephen Gallagher
Modified: 2015-04-12 02:42 UTC (History)
12 users (show)

Fixed In Version: virt-manager-1.1.0-4.git310f6527.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 00:46:25 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (83.12 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: cgroup (191 bytes, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: core_backtrace (34.10 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: dso_list (22.42 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: environ (1.68 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: maps (105.28 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: open_fds (1.07 KB, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: proc_pid_status (978 bytes, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details
File: var_log_messages (395 bytes, text/plain)
2014-08-29 14:48 UTC, Stephen Gallagher
no flags Details

Description Stephen Gallagher 2014-08-29 14:48:29 UTC
Description of problem:
At the conclusion of the install of Fedora 21 Server Alpha TC4 from the DVD ISO, I clicked the reboot button in Anaconda. As it started to reboot, virt-manager crashed.

Version-Release number of selected component:
virt-manager-1.0.1-3.fc21.1

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/bin/python2 -tt /usr/share/virt-manager/virt-manager
crash_function: g_socket_constructed
executable:     /usr/bin/python2.7
kernel:         3.16.1-301.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            13041

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_socket_constructed at /lib64/libgio-2.0.so.0
 #3 g_object_new_internal at /lib64/libgobject-2.0.so.0
 #4 g_object_new_valist at /lib64/libgobject-2.0.so.0
 #5 g_initable_new_valist at /lib64/libgio-2.0.so.0
 #6 g_initable_new at /lib64/libgio-2.0.so.0
 #7 g_socket_new_from_fd at /lib64/libgio-2.0.so.0
 #8 spice_channel_coroutine at /lib64/libspice-client-glib-2.0.so.8
 #9 coroutine_trampoline at /lib64/libspice-client-glib-2.0.so.8
 #10 continuation_trampoline at /lib64/libspice-client-glib-2.0.so.8
 #11 ?? at /lib64/libc.so.6

Comment 1 Stephen Gallagher 2014-08-29 14:48:32 UTC
Created attachment 932697 [details]
File: backtrace

Comment 2 Stephen Gallagher 2014-08-29 14:48:33 UTC
Created attachment 932698 [details]
File: cgroup

Comment 3 Stephen Gallagher 2014-08-29 14:48:34 UTC
Created attachment 932699 [details]
File: core_backtrace

Comment 4 Stephen Gallagher 2014-08-29 14:48:35 UTC
Created attachment 932700 [details]
File: dso_list

Comment 5 Stephen Gallagher 2014-08-29 14:48:36 UTC
Created attachment 932701 [details]
File: environ

Comment 6 Stephen Gallagher 2014-08-29 14:48:37 UTC
Created attachment 932703 [details]
File: limits

Comment 7 Stephen Gallagher 2014-08-29 14:48:38 UTC
Created attachment 932704 [details]
File: maps

Comment 8 Stephen Gallagher 2014-08-29 14:48:39 UTC
Created attachment 932705 [details]
File: open_fds

Comment 9 Stephen Gallagher 2014-08-29 14:48:40 UTC
Created attachment 932706 [details]
File: proc_pid_status

Comment 10 Stephen Gallagher 2014-08-29 14:48:41 UTC
Created attachment 932707 [details]
File: var_log_messages

Comment 11 Cole Robinson 2014-09-20 23:48:26 UTC
*** Bug 1135808 has been marked as a duplicate of this bug. ***

Comment 12 Stephen Gallagher 2014-10-24 09:58:34 UTC
Still experiencing this issue pretty much whenever a guest machine reboots while I have a viewer open on it.

Comment 13 Cole Robinson 2014-11-16 17:12:07 UTC
*** Bug 1049665 has been marked as a duplicate of this bug. ***

Comment 14 Cole Robinson 2014-11-16 19:54:50 UTC
I tried to reproduce a bunch of times but couldn't make it stick. That said, there's a patch upstream now which sounds like it might fix this (I did my testing without the patch FWIW). I'll push a build with this patch and mark this bug fixed, but if it gathers any more abrt hits I'll reopen it.

commit 5daee287d91080d24c4e7ae8a0eaf4e356331bae
Author: Marc-André Lureau <marcandre.lureau@redhat.com>
Date:   Sun Nov 9 22:02:30 2014 +0100

    tunnels: do not close unowned fd

Comment 15 Fedora Update System 2014-11-16 20:10:46 UTC
virt-manager-1.1.0-4.git310f6527.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/virt-manager-1.1.0-4.git310f6527.fc21

Comment 16 Fedora Update System 2014-11-18 12:13:49 UTC
Package virt-manager-1.1.0-4.git310f6527.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.1.0-4.git310f6527.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15270/virt-manager-1.1.0-4.git310f6527.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Blocker Bugs Application 2014-11-18 13:22:28 UTC
Proposed as a Freeze Exception for 21-final by Fedora user sgallagh using the blocker tracking app because:

 This is an extremely common crash bug. It would reflect poorly on us to ship without this fix, if we can get sufficient karma in time for the release candidate.

Comment 18 Cole Robinson 2014-11-18 13:26:20 UTC
(In reply to Fedora Blocker Bugs Application from comment #17)
> Proposed as a Freeze Exception for 21-final by Fedora user sgallagh using
> the blocker tracking app because:
> 
>  This is an extremely common crash bug. It would reflect poorly on us to
> ship without this fix, if we can get sufficient karma in time for the
> release candidate.

I should note, I still haven't managed to reproduce this. So sgallagh (or anyone that can reliably reproduce), please let me know if the build fixes the issue

Comment 19 Stephen Gallagher 2014-11-18 13:33:56 UTC
(In reply to Cole Robinson from comment #18)
> (In reply to Fedora Blocker Bugs Application from comment #17)
> > Proposed as a Freeze Exception for 21-final by Fedora user sgallagh using
> > the blocker tracking app because:
> > 
> >  This is an extremely common crash bug. It would reflect poorly on us to
> > ship without this fix, if we can get sufficient karma in time for the
> > release candidate.
> 
> I should note, I still haven't managed to reproduce this. So sgallagh (or
> anyone that can reliably reproduce), please let me know if the build fixes
> the issue

I've been able to reproduce it consistently when using virt-manager to install Fedora 21 pre-releases remotely (via qemu+ssh://) on a RHEL 7.0 VM host. It consistently crashes when rebooting the installed system after anaconda completes.

I'll attempt to verify this fix now.

Comment 20 Cole Robinson 2014-11-18 13:45:39 UTC
Thanks. I wasn't testing with an ssh URI, maybe that was the issue

Comment 21 Mike Ruckman 2014-11-19 19:17:37 UTC
Discussed in 2014-11-19 blocker review meeting. virt-manager is a part of Server DVD, and it would great to have this crash fixed. It's not installed by default, so the change should be quite safe.

Comment 22 Fedora Update System 2014-11-22 00:46:25 UTC
virt-manager-1.1.0-4.git310f6527.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Gabriel 2014-12-27 20:31:47 UTC
Another user experienced a similar problem:

AL intentar conectar a una instancia Libvirt en un centos7 remoto

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/bin/python2 -tt /usr/share/virt-manager/virt-manager
crash_function: g_socket_constructed
executable:     /usr/bin/python2.7
kernel:         3.17.7-300.fc21.x86_64
package:        virt-manager-1.1.0-4.git310f6527.fc21
reason:         python2.7 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 24 Alan Schmidt 2015-02-10 20:45:08 UTC
Abrt thinks I just experienced bug 1135808, which is marked as a duplicate of this bug.

I am using virt-manager 1.1.0.4.git310f6527.fc21.noarch.

Comment 25 Dr. David Alan Gilbert 2015-03-23 15:34:53 UTC
I've just tripeed this again; f21 virt-manager-1.1.0-4.git310f6527.fc21.noarch

Comment 26 Cole Robinson 2015-04-12 02:42:23 UTC

*** This bug has been marked as a duplicate of bug 1135808 ***


Note You need to log in before you can comment on or make changes to this bug.