Bug 1135808 - [abrt] virt-manager: g_socket_details_from_fd(): python2.7 killed by SIGTRAP
Summary: [abrt] virt-manager: g_socket_details_from_fd(): python2.7 killed by SIGTRAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:2cad46b9dd8e339d674d9d3747c...
: 1135546 1201016 (view as bug list)
Depends On:
Blocks: F21FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-08-31 20:52 UTC by jimtahu
Modified: 2015-04-21 18:56 UTC (History)
12 users (show)

Fixed In Version: virt-manager-1.1.0-7.git6dbe19bd8.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:56:47 UTC


Attachments (Terms of Use)
File: backtrace (76.27 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: cgroup (180 bytes, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: core_backtrace (26.44 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: dso_list (20.35 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: environ (1.46 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: limits (1.29 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: maps (101.88 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: open_fds (1.65 KB, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: proc_pid_status (953 bytes, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details
File: var_log_messages (190 bytes, text/plain)
2014-08-31 20:52 UTC, jimtahu
no flags Details

Description jimtahu 2014-08-31 20:52:30 UTC
Description of problem:
I shut down a remote VM. My client crashed when the VM powered off, I was able to start the client and reconnect to the host.

Version-Release number of selected component:
virt-manager-1.0.1-3.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/bin/python2 -tt /usr/share/virt-manager/virt-manager
crash_function: g_socket_details_from_fd
executable:     /usr/bin/python2.7
kernel:         3.15.10-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_socket_details_from_fd at gsocket.c:368
 #3 g_socket_constructed at gsocket.c:586
 #4 g_object_new_internal at gobject.c:1785
 #5 g_object_new_valist at gobject.c:2002
 #6 g_initable_new_valist at ginitable.c:227
 #7 g_initable_new at ginitable.c:149
 #8 g_socket_new_from_fd at gsocket.c:1072
 #9 spice_channel_coroutine at spice-channel.c:2231
 #10 coroutine_trampoline at coroutine_ucontext.c:63
 #11 continuation_trampoline at continuation.c:55

Comment 1 jimtahu 2014-08-31 20:52:32 UTC
Created attachment 933177 [details]
File: backtrace

Comment 2 jimtahu 2014-08-31 20:52:33 UTC
Created attachment 933178 [details]
File: cgroup

Comment 3 jimtahu 2014-08-31 20:52:34 UTC
Created attachment 933179 [details]
File: core_backtrace

Comment 4 jimtahu 2014-08-31 20:52:35 UTC
Created attachment 933180 [details]
File: dso_list

Comment 5 jimtahu 2014-08-31 20:52:35 UTC
Created attachment 933181 [details]
File: environ

Comment 6 jimtahu 2014-08-31 20:52:36 UTC
Created attachment 933182 [details]
File: limits

Comment 7 jimtahu 2014-08-31 20:52:37 UTC
Created attachment 933183 [details]
File: maps

Comment 8 jimtahu 2014-08-31 20:52:38 UTC
Created attachment 933184 [details]
File: open_fds

Comment 9 jimtahu 2014-08-31 20:52:39 UTC
Created attachment 933185 [details]
File: proc_pid_status

Comment 10 jimtahu 2014-08-31 20:52:39 UTC
Created attachment 933186 [details]
File: var_log_messages

Comment 11 jimtahu 2014-08-31 20:56:54 UTC
Probably worth mentioning that the remote host is running gentoo libvirtd version 1.2.6

Comment 12 Cole Robinson 2014-09-20 23:48:26 UTC

*** This bug has been marked as a duplicate of bug 1135546 ***

Comment 13 Cole Robinson 2015-04-12 02:42:06 UTC
This bug seems to be the winner, faf has 300 hits for it. So reopening this

Comment 14 Cole Robinson 2015-04-12 02:42:23 UTC
*** Bug 1135546 has been marked as a duplicate of this bug. ***

Comment 15 Cole Robinson 2015-04-12 02:43:29 UTC
*** Bug 1201016 has been marked as a duplicate of this bug. ***

Comment 16 Cole Robinson 2015-04-12 02:54:08 UTC
Yeah so this issue isn't fixed in fedora yet. I think upstream is fixed now:

commit e2cdfd651ca0511e078c5ffd4da3644909767671
Author: Cole Robinson <crobinso@redhat.com>
Date:   Sat Apr 11 22:10:46 2015 -0400

    sshtunnels: Don't use python socket for FD we pass to spice

Previously we used python's socket library for all our FD handling when opening an ssh tunnel. However these higher level socket objects close the backing fd when they are garbage collected, and they were going out of scope right before we tear down the spice widget.

That commit fixes things to pass a non-socket fd to spice. It won't apply as-is to f21 and f20 but it shouldn't be too hard to backport something similar.

Comment 17 Fedora Update System 2015-04-13 22:44:30 UTC
virt-manager-1.1.0-7.git6dbe19bd8.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/virt-manager-1.1.0-7.git6dbe19bd8.fc22

Comment 18 Fedora Update System 2015-04-21 18:56:47 UTC
virt-manager-1.1.0-7.git6dbe19bd8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.