Bug 1135551 - bundle deployment handover fails when app runtime name != war name
Summary: bundle deployment handover fails when app runtime name != war name
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ER02
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1050014
TreeView+ depends on / blocked
 
Reported: 2014-08-29 15:13 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-12-11 14:04:58 UTC


Attachments (Terms of Use)
handover_failure (190.10 KB, application/octet-stream)
2014-08-29 15:13 UTC, Armine Hovsepyan
no flags Details
bundle_app_runtime_name (114.45 KB, application/octet-stream)
2014-08-29 15:14 UTC, Armine Hovsepyan
no flags Details
eap_doamin_runtime_name_example (103.50 KB, application/octet-stream)
2014-08-29 15:15 UTC, Armine Hovsepyan
no flags Details
handover_passed (206.97 KB, application/octet-stream)
2014-09-04 11:44 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-08-29 15:13:38 UTC
Created attachment 932710 [details]
handover_failure

Description of problem:
bundle deployment handover fails when app runtime name != war name

Version-Release number of selected component (if applicable):
jon 3.3 er01.1

How reproducible:
always

Steps to Reproduce:
1. Create a bundle with 'application_war' in it
2. Deploy bundle giving a 'runtime name != application_war name'
3. 

Actual results:
deployment fails on handover 

Expected results:
deployment goes correct, war is visible under managed server with 'application_war name' & corresponding 'runtime name'


Additional info:
deployment to domain server directly works correctly with edited 'runtime name'
screen-shots attached

Comment 1 Armine Hovsepyan 2014-08-29 15:14:25 UTC
Created attachment 932711 [details]
bundle_app_runtime_name

Comment 2 Armine Hovsepyan 2014-08-29 15:15:01 UTC
Created attachment 932712 [details]
eap_doamin_runtime_name_example

Comment 3 Jay Shaughnessy 2014-08-29 19:34:45 UTC

Thomas, I'm not sure but I wonder if this is confusion similar to what we fixed in Bug 1119781?

Looking at the code I'm not sure, there are two cases, domain and standalone.  In both StandaloneASComponent and HostControllerComponent the handleDeployment(BundleHandoverRequest) has a redeployer object I'm unsure of.  It may be correct or maybe it should be using filename as opposed to runtimename. I have the feeling that it's actually OK as is.

If the problem is in domain only (which I think it is given the description, then the problem may be the line:

          serverGroupDeploymentAddress.add("deployment", runtimeName);

I feel like that maybe should be filename.

Anyway, thoughts?

Comment 4 Thomas Segismont 2014-08-30 09:42:35 UTC
(In reply to Jay Shaughnessy from comment #3)
> 
> Thomas, I'm not sure but I wonder if this is confusion similar to what we
> fixed in Bug 1119781?
> 

Yes, it is related.

> Looking at the code I'm not sure, there are two cases, domain and
> standalone.  In both StandaloneASComponent and HostControllerComponent the
> handleDeployment(BundleHandoverRequest) has a redeployer object I'm unsure
> of.  It may be correct or maybe it should be using filename as opposed to
> runtimename. I have the feeling that it's actually OK as is.
> 

So have I. Maybe QE has a test case for redeployment but this BZ is about deployment of new application as I understand it.

> If the problem is in domain only (which I think it is given the description,
> then the problem may be the line:
> 
>           serverGroupDeploymentAddress.add("deployment", runtimeName);
> 
> I feel like that maybe should be filename.
> 
> Anyway, thoughts?

Right. After you fixed Bug 1119781, I pushed this to release/jon3.3.x:

=====
commit 4afff8009c59cb1924180d5a237523f1b3d3b63b
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Thu Jul 24 16:09:23 2014 +0200

    Bug 1050014 - Cannot deploy bundle to EAP domain mode
    
    Deployment node must be created with the filename, not the runtime name
    
    See also Bug 1119781 - runtime name provided for deployment child creation overrides application name and path
    
    Cherry-picked from cede4b6
=====

While I think the changes in commit 4afff8009c59cb1924180d5a237523f1b3d3b63b are correct for a standalone server, I believe you're right, I forgot to update the serverGroupDeploymentAddress initialization code in HostControllerComponent.

Comment 5 Thomas Segismont 2014-08-30 10:08:35 UTC
Fixed in master

commit 454bcaed5fe10a6f912c929b227274046d0396e4
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Sat Aug 30 12:07:17 2014 +0200
    
The server group deployment node was created correctly (with name = filename) but then erroneously addressed (with name = runtimename)

Comment 6 Michael Burman 2014-09-01 08:44:25 UTC
Cherry-picked to release/jon3.3.x:

commit e35bca4532c7fe1aa36bab18851f62966e7a0b5c
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Sat Aug 30 12:07:17 2014 +0200

    Bug 1135551 - bundle deployment handover fails when app runtime name != war name
    
    The server group deployment node was created correctly (with name = filename) but then erroneously addressed (with name = runtimename)
    
    (cherry picked from commit 454bcaed5fe10a6f912c929b227274046d0396e4)

Comment 7 Simeon Pinder 2014-09-03 20:31:57 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 8 Armine Hovsepyan 2014-09-04 11:44:53 UTC
Created attachment 934375 [details]
handover_passed

Comment 9 Armine Hovsepyan 2014-09-04 11:45:13 UTC
verified in JON 3.3 ER02
screen-shot attached


Note You need to log in before you can comment on or make changes to this bug.