Bug 1135577 - [GSS] (6.4.0) [CXF-5753] Redefinition of default namespace causes parsing error when JAX-WS handler is configured
Summary: [GSS] (6.4.0) [CXF-5753] Redefinition of default namespace causes parsing err...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.4.0
Assignee: Alessio Soldano
QA Contact: Rostislav Svoboda
URL:
Whiteboard:
: 1150931 (view as bug list)
Depends On:
Blocks: 1115213 1135578 1135579 1143935
TreeView+ depends on / blocked
 
Reported: 2014-08-29 17:03 UTC by Kyle Lape
Modified: 2019-08-02 07:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1135578 (view as bug list)
Environment:
Last Closed: 2019-08-02 07:27:18 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA CXF-5753 None None None Never

Description Kyle Lape 2014-08-29 17:03:55 UTC
Example XML fragment that fails:

<a xmlns="someNamespace">
  <b xmlns=""/>
</a>

Error:

element {someNamespace}b is found instead of the expected {}b

Obviously <b> is not qualified with "someNamespace", so CXF is reading it wrong.

Comment 1 Kyle Lape 2014-08-29 17:06:15 UTC
This is already fixed in CXF 2.7.12.

Comment 2 Tadayoshi Sato 2014-10-10 01:12:10 UTC
*** Bug 1150931 has been marked as a duplicate of this bug. ***

Comment 3 Rostislav Svoboda 2014-11-26 09:56:10 UTC
Verified on EAP 6.4.0 DR11 using slightly changed reproducer from https://issues.apache.org/jira/browse/CXF-5811

mvn -s ~/TESTING/settings-mead.xml clean package -Dcxf.version=2.7.11.redhat-3 
  fail - EAP 6.3.0 bits

mvn -s ~/TESTING/settings-mead.xml clean package -Dcxf.version=2.7.13.redhat-4 
  pass - EAP 6.4.0 DR11 bits


Note You need to log in before you can comment on or make changes to this bug.