Bug 1135580 - LuceneCacheLoader doing unecessary IO
Summary: LuceneCacheLoader doing unecessary IO
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.3.1,6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: 6.3.1
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
: 1135608 (view as bug list)
Depends On:
Blocks: 1139645
TreeView+ depends on / blocked
 
Reported: 2014-08-29 17:13 UTC by Gustavo Fernandes
Modified: 2015-01-26 14:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously in JBoss Data Grid, after a read-only Lucene index was preloaded via the cacheloader, the backing index was still accessed for small segments. This is now fixed in JBoss Data Grid 6.3.1 so that preloading a read-only Lucene index works as expected.
Clone Of:
: 1139645 (view as bug list)
Environment:
Last Closed: 2015-01-26 14:04:25 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-2932 Major Resolved Preloading a read only index in a cache will never hit the cacheloader 2015-05-13 16:56:58 UTC
Red Hat Issue Tracker ISPN-4601 Major Resolved DirectoryLoaderAdaptor computes the auto-chunk factor applying wrong rounding 2015-05-13 16:56:57 UTC

Description Gustavo Fernandes 2014-08-29 17:13:13 UTC
Description of problem:

The incorrect calculation can provoke unecessary IO during LuceneCacheLoader usage 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Gustavo Fernandes 2014-08-29 19:00:27 UTC
PR for jdg 6.3.x: https://github.com/infinispan/jdg/pull/217
PR for jdg 6.4.x: https://github.com/infinispan/jdg/pull/218

Comment 3 Gustavo Fernandes 2014-08-29 20:31:00 UTC
*** Bug 1135608 has been marked as a duplicate of this bug. ***

Comment 4 Adrian Nistor 2014-08-30 11:36:14 UTC
Integrated in both 6.3.x and 6.4.x.


Note You need to log in before you can comment on or make changes to this bug.