Bug 1135661 - Cursor pointer sometimes disappear in XWayland apps
Summary: Cursor pointer sometimes disappear in XWayland apps
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1278316 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2014-08-29 23:16 UTC by optimisme
Modified: 2016-10-26 05:37 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-01 02:12:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1278316 None CLOSED [XWayland] Mouse pointer doesn't get changed by applications or sporadically disappears 2019-09-09 08:49:06 UTC

Internal Links: 1278316

Description optimisme 2014-08-29 23:16:30 UTC
Description of problem:
Whan overing a link on firefox, the cursor 'pointer' is not shown

Version-Release number of selected component (if applicable):
Fedora-Live-Workstation-x86_64-21-20140827

How reproducible:
Allways

Steps to Reproduce:
1.Using a Gnome+Wayland session
2.Open Firefox
3.Put the cursor over a link
4.The cursor does not show the 'pointer' icon

Actual results:
Arrow cursor is shown

Expected results:
Pointer cursor is shown

Additional info:

Comment 1 Sreekumar R 2014-12-04 11:06:26 UTC
Similar issue happens with evolution as well. The pointer is not shown in most of the areas in evolution like, message list, message preview etc.

It works fine for a normal gnome session, so I am guessing it is a wayland issue.

Comment 2 Jaroslav Reznik 2015-03-03 16:15:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 M. Edward (Ed) Borasky 2015-03-09 04:19:18 UTC
I saw something like this on the F22 Alpha RC3 today in a Virtual Machine Manager guest. If there's anything I can do to troubleshoot, let me know.

Comment 4 Patryk Zawadzki 2015-10-12 09:19:57 UTC
I am experiencing the same behaviour with Fedora 23. Unless there is at least one GTK3 application running, there is no mouse cursor in XWayland applications. As soon as I launch a GTK3 app, other apps start to show the last cursor the native app used (be it beam, resize, busy or maybe the regular pointer arrow). The XWayland apps seem unable to change the cursor when hovering special areas like hyperlinks in Chrome. If the last used cursor is an animated one, it will no longer animate when hovering an XWayland app which seems to indicate that the software gave up updating the cursor and it's just the hardware cursor rendering the last bitmap assigned.

Comment 5 Per Arnold Blåsmo 2015-11-03 07:46:58 UTC
I was just testing Wayland on Fedora 23 with a dual screen setuo, and had the same missing cursor in my Firefox application.

Starting Nautilus made the cursor appear in Firefox, with the same "form" as it had when leaving the Nautilus window.

Basically confirming @Patryk's experience in comment 4.

Comment 6 Olivier Fourdan 2015-11-09 14:19:52 UTC
(In reply to Per Arnold Blåsmo from comment #5)
> I was just testing Wayland on Fedora 23 with a dual screen setuo, and had
> the same missing cursor in my Firefox application.
> 
> Starting Nautilus made the cursor appear in Firefox, with the same "form" as
> it had when leaving the Nautilus window.
> 
> Basically confirming @Patryk's experience in comment 4.

I think I've seen this in F22 but I fail to reproduce that in F23.

I log in GNOME Wayland session, then run just firefox and the mouse cursor changes as expected over the hyperlinks.

Same with google-chrome. Beside, GNOME is using gtk3 so as soon gnome-shell starts you already have a gtk3 application so I am not sure I understand the relationship here.

Is there anything particular about your setup that would explain the difference? What kind of hardware do you have?

Do you have gdm running on Wayland (default)? If so do you see the mouse cursor in gdm on Wayland?

Comment 7 Juan Orti Alcaine 2015-11-18 10:04:56 UTC
I experience this issue consistently in F23. The mouse cursor behaves oddly in XWayland applications.

Versions:
ibus-wayland-1.5.11-1.fc23.x86_64
libwayland-client-1.9.0-1.fc23.x86_64
xorg-x11-server-Xwayland-1.18.0-1.fc23.x86_64
mesa-libwayland-egl-11.0.4-1.20151105.fc23.x86_64
libwayland-cursor-1.9.0-1.fc23.x86_64
libwayland-server-1.9.0-1.fc23.x86_64
gnome-session-wayland-session-3.18.1.2-2.fc23.x86_64
mutter-3.18.1-4.fc23.x86_64

Comment 8 Christian Stadelmann 2015-11-24 21:25:21 UTC
I think this is an issue in Xorg's XWayland. Can you please reassing?

Isn't this the same issue as bug #1278316 ?

Comment 9 Kamil Páral 2015-12-08 10:56:49 UTC
I have experienced the same thing as in comment 4 recently on Fedora 23, but can't reproduce it. As long as I had gnome-terminal running, I had cursor in Firefox, otherwise it was invisible.

Comment 10 Zbigniew Jędrzejewski-Szmek 2015-12-09 13:49:32 UTC
I can observe this occasionally with Firefox under up2date F23.

Comment 11 Dan Loomis 2015-12-11 04:03:19 UTC
I just started observing the cursor disappearing in Firefox tonight.  I've been running Wayland for a month and this is the firse I've seen of this problem.  The last upgrade was on 12/08 and I installed Gnome Chess last night.

Comment 12 Malar Kannan 2015-12-20 09:31:51 UTC
same here

Comment 13 Malar Kannan 2015-12-20 09:50:30 UTC
I have found a way to make it reappear though - by opening gnome-terminal*, keeping it over firefox and hover over it and doing alt-tag leave the cursor visible
(*possibly even other apps where cursor doesn't disappear on hover)

Comment 14 Malar Kannan 2015-12-20 10:57:58 UTC
How to reproduce: open firefox play a video (youtube.com) hover mouse over the video cursor dissapears.

Comment 15 Olivier Fourdan 2015-12-21 07:44:19 UTC
(In reply to Malar Kannan from comment #14)
> How to reproduce: open firefox play a video (youtube.com) hover mouse over
> the video cursor dissapears.

Firefox uses XWayland so this is most likely bug 1278316 for which there is a fix merged upstream.

Comment 16 Dan Loomis 2016-01-10 07:31:13 UTC
I lost work in progress tonight because of this bug.   I'm done with Wayland for now.   I might switch back when I see some substantial updates land in F23.

Comment 17 Christian Stadelmann 2016-02-09 16:32:13 UTC
*** Bug 1278316 has been marked as a duplicate of this bug. ***

Comment 18 Chris McCabe 2016-07-20 21:06:50 UTC
I don't know if this is the same issue or not, but I am running Fedora 24 with Wayland and I lose the mouse within all applications very regularly, averaging about once an hour. The mouse works in the Gnome shell (which occasionally crashes), so the only thing I can do is Gnome stuff, including closing windows. It seems to be caused by Intellij because if I close the Intellij windows (by clicking on the X in the upper right), I get the mouse back in other applications.

Comment 19 Christian Stadelmann 2016-07-21 09:59:40 UTC
This bug is mostly or completely gone on F24 for me, on several machines.

@Chris McCabe: Are you running Fedora 23 or 24?

If you are running Fedora 23, please upgrade to 24 or don't use wayland. Running an old version of bleeding edge technology isn't expected to be bug-free. Many bugs in wayland got resolved in the mean time.

If "losing the mouse" means that your cursor is still visible but applications don't respond to mouse input any more, please have a look at bug #1358700.

Comment 20 Chris McCabe 2016-07-21 12:59:42 UTC
(In reply to Christian Stadelmann from comment #19)
> This bug is mostly or completely gone on F24 for me, on several machines.
> 
> @Chris McCabe: Are you running Fedora 23 or 24?
> 

I am running Fedora 24 as I stated. Bug #1358700 is exactly what I am experiencing.

Comment 21 Christian Stadelmann 2016-07-21 13:19:00 UTC
I guess this bug can be closed.


(In reply to Chris McCabe from comment #20)
> I am running Fedora 24 as I stated. Bug #1358700 is exactly what I am
> experiencing.

You might want to add yourself to its CC list then.

Comment 22 Anass Ahmed 2016-10-21 16:05:56 UTC
I don't know if it should be reported here or on a separate bug, but it's a cosmetic issue: the pointer in the full screen videos (in Firefox, and VLC for example) doesn't hide the mouse cursor at the beginning. I should move the cursor a little bit, so it can be hidden with the player-controllers (which were already hidden, but appeared with the movement).

This happens every time with Youtube videos in Firefox and also VLC, but doesn't happen with Totem.

How to reproduce in VLC:
1. Open a video.
2. Switch to any other app.
3. Switch back to VLC with Super+Tab (not the mouse).
4. Press "F" to activate the full-screen mode.
5. You should now see the cursor in the full-screen mode, if you moved the mouse, it will show the player controllers then disappear with them.

Comment 23 Kamil Páral 2016-10-25 12:02:45 UTC
(In reply to Anass Ahmed from comment #22)
> I don't know if it should be reported here or on a separate bug, 

I can reproduce that, and yes, it's a different bug and should be reported separately. Please file a new bug and link it here, thanks.

Comment 24 Anass Ahmed 2016-10-26 05:37:15 UTC
(In reply to Kamil Páral from comment #23)
> (In reply to Anass Ahmed from comment #22)
> > I don't know if it should be reported here or on a separate bug, 
> 
> I can reproduce that, and yes, it's a different bug and should be reported
> separately. Please file a new bug and link it here, thanks.

I filed Bug 1388750, please follow it there.


Note You need to log in before you can comment on or make changes to this bug.