Bug 1278316 - [XWayland] Mouse pointer doesn't get changed by applications or sporadically disappears
Summary: [XWayland] Mouse pointer doesn't get changed by applications or sporadically ...
Keywords:
Status: CLOSED DUPLICATE of bug 1135661
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1282818 1286342 (view as bug list)
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2015-11-05 09:07 UTC by Christian Stadelmann
Modified: 2016-02-09 16:33 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-09 16:32:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1135661 None None None Never

Internal Links: 1135661

Description Christian Stadelmann 2015-11-05 09:07:09 UTC
Description of problem:
On different applications running in XWayland, including firefox and eclipse (started using GDK_BACKEND=x11) and some gtk2+python2 applications, the mouse cursor doesn't change any more when e.g. hovering on links. Sometimes it completely disappears. Sometimes you see a text cursor for all of the GUI, including buttons, links, …. Sometimes you see resize cursors until you click somewhere into your application's window.

Version-Release number of selected component (if applicable):
libwayland-client-1.9.0-1.fc23.x86_64
libwayland-cursor-1.9.0-1.fc23.x86_64
libwayland-server-1.9.0-1.fc23.x86_64
xorg-x11-server-Xwayland-1.18.0-0.6.20151027.fc23.x86_64

How reproducible:
The "mouse pointer doesn't change" part: reliably
The "mouse pointer disappears" part: not quite reliably

Additional info:
This issue doesn't affect pure Gtk3 applications running with wayland backend as e.g. gedit, nautilus, evolution. I could not reproduce this issue on a gnome+X session, only on Gnome+Wayland.

Comment 1 Olivier Fourdan 2015-11-09 14:34:03 UTC
The followign patch Jonas sent to the xorg-devel mailing list for Xwayland might help here:

http://lists.freedesktop.org/archives/xorg-devel/2015-October/047541.html

Comment 2 Kamil Páral 2015-11-25 09:50:43 UTC
*** Bug 1282818 has been marked as a duplicate of this bug. ***

Comment 3 Kamil Páral 2015-11-30 10:20:23 UTC
*** Bug 1286342 has been marked as a duplicate of this bug. ***

Comment 4 Olivier Fourdan 2015-12-02 08:07:19 UTC
Jonas' patch menetioned in comment 1 has now been pushed upstream as commit 07941a5:

http://cgit.freedesktop.org/xorg/xserver/commit/?id=07941a5

Comment 5 Anass Ahmed 2015-12-25 14:29:56 UTC
Maybe you can review the attached video on this comment:
https://bugzilla.redhat.com/show_bug.cgi?id=1268495#c10

The cursor seems to be stuck when changing shapes on Wayland GTK3 apps.

Comment 6 Christian Stadelmann 2016-02-09 16:32:13 UTC
This issue will be fixed in the next xorg xserver release.


(In reply to Anass Ahmed from comment #5)
> Maybe you can review the attached video on this comment:
> https://bugzilla.redhat.com/show_bug.cgi?id=1268495#c10
> 
> The cursor seems to be stuck when changing shapes on Wayland GTK3 apps.

I think you mean it doesn't get changed when moving onto another window. I can see that and it looks like you are running into the same issue.

*** This bug has been marked as a duplicate of bug 1135661 ***


Note You need to log in before you can comment on or make changes to this bug.