Bug 1135680 - yumdownloader: UnicodeDecodeError: 'utf8' codec can't decode byte 0xd2 in position 16: invalid continuation byte
Summary: yumdownloader: UnicodeDecodeError: 'utf8' codec can't decode byte 0xd2 in pos...
Keywords:
Status: CLOSED DUPLICATE of bug 1135632
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2014-08-30 09:29 UTC by Richard W.M. Jones
Modified: 2014-09-02 10:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 10:32:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-08-30 09:29:24 UTC
Description of problem:

All yumdownloader commands fail in Rawhide for some bizarre reason,
since yesterday.  This has only been seen on i686.

The error is:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1307, in _retrieve
    self.fo.write(buf.decode('utf-8'))
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd2 in position 16: invalid continuation byte
file:///builddir/build/BUILD/libguestfs-1.27.34/repo/repodata/5687369b77501c31620f70fb1036e9e39471969b5e9b3672472f7dfbef610dfc-primary.sqlite.bz2: [Errno 14] curl#23 - "Failed writing body (0 != 16383)"
Trying other mirror.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1307, in _retrieve
    self.fo.write(buf.decode('utf-8'))
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd2 in position 16: invalid continuation byte
file:///builddir/build/BUILD/libguestfs-1.27.34/repo/repodata/5687369b77501c31620f70fb1036e9e39471969b5e9b3672472f7dfbef610dfc-primary.sqlite.bz2: [Errno 14] curl#23 - "Failed writing body (0 != 16383)"
Trying other mirror.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1307, in _retrieve
    self.fo.write(buf.decode('utf-8'))
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xd2 in position 16: invalid continuation byte
file:///builddir/build/BUILD/libguestfs-1.27.34/repo/repodata/5687369b77501c31620f70fb1036e9e39471969b5e9b3672472f7dfbef610dfc-primary.sqlite.bz2: [Errno 14] curl#23 - "Failed writing body (0 != 16383)"
Trying other mirror.
failure: repodata/5687369b77501c31620f70fb1036e9e39471969b5e9b3672472f7dfbef610dfc-primary.sqlite.bz2 from local: [Errno 256] No more mirrors to try.
file:///builddir/build/BUILD/libguestfs-1.27.34/repo/repodata/5687369b77501c31620f70fb1036e9e39471969b5e9b3672472f7dfbef610dfc-primary.sqlite.bz2: [Errno 14] curl#23 - "Failed writing body (0 != 16383)"
supermin: /usr/bin/yumdownloader -c '/builddir/build/BUILD/libguestfs-1.27.34/yum.conf' --destdir '/tmp/supermine6e4e6.tmpdir/9tcf1x40' 'e2fsprogs.i686' 'iproute.i686' 'nilfs-utils.i686' 'openssh-clients.i686' 'syslinux-extlinux.i686' 'systemd.i686' 'vim-minimal.i686' 'zfs-fuse.i686' 'bash.i686' 'coreutils.i686' 'file.i686' 'grep.i686' 'lvm2.i686' 'mdadm.i686' 'util-linux.i686' 'audit-libs.i686' 'dbus.i686' 'fuse.i686' 'glibc.i686' 'glibc-common.i686' 'groff-base.i686' 'info.i686' 'iptables.i686' 'krb5-libs.i686' 'libattr.i686' 'libpwquality.i686' 'libuser.i686' 'mtools.i686' 'openldap.i686' 'openssh.i686' 'openssl-libs.i686' 'pam.i686' 'shadow-utils.i686' 'crypto-policies.noarch' 'dracut.i686' 'libsemanage.i686' 'nss.i686' 'setup.noarch' 'trousers.i686' 'fedora-release.noarch' 'fedora-repos.noarch' 'fedora-repos-rawhide.noarch': command failed, see earlier errors

Version-Release number of selected component (if applicable):

yum-utils 1.1.31-24.fc21

How reproducible:

100%

Steps to Reproduce:
1. See yumdownloader command at the end of that trace above.

Comment 1 Valentina Mukhamedzhanova 2014-09-02 10:32:56 UTC

*** This bug has been marked as a duplicate of bug 1135632 ***


Note You need to log in before you can comment on or make changes to this bug.