Bug 113586 - ypserv starts before cups --> ypserv sometimes binds cups IPP port
Summary: ypserv starts before cups --> ypserv sometimes binds cups IPP port
Status: CLOSED DUPLICATE of bug 103401
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-15 16:34 UTC by Gianni Giardina
Modified: 2007-04-18 17:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gianni Giardina 2004-01-15 16:34:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
The problem is similar to the one reported in Bug #97767.

YPSERV is started before the cups daemon:
- the ypserv daemon selects a free port < 1024 and _sometimes_ select
the cups IPP port.

Which means --> cups cannot start, because the IPP Port is in use and
exits with (message from /var/log/messages):
--snip--
cupsd: Child exited with status 98!
--snip--

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.0.3

How reproducible:
Sometimes

Steps to Reproduce:
1. reboot until ;-) ypserv runs on cups IPP port
2. cups will not start, since tcp/631 is already bound

Additional info:

Comment 1 Tim Waugh 2004-01-15 16:40:39 UTC

*** This bug has been marked as a duplicate of 103401 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.