Bug 113592 - Hyperthreading does not show additional processors on PC-DL motherboard
Summary: Hyperthreading does not show additional processors on PC-DL motherboard
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-15 17:12 UTC by Giorel
Modified: 2015-01-04 22:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 21:02:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport bzip, should include dmesg entry (210.25 KB, text/plain)
2004-01-16 16:38 UTC, Giorel
no flags Details

Description Giorel 2004-01-15 17:12:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
cat /proc/cpuinfo

only shows cpu0 and cpu1 when on smp
only shows cpu0 when not on smp

But this is dual xeon machine, and bootup says hyperthreading is enabled.

Tried noapic parameter...no effect

This is the motherboard:
http://usa.asus.com/products/server/srv-mb/pc-dl/overview.HTM

no noht passed in kernel or /etc/grub.conf, ht just regular flag on
cpuinfo, everything in BIOS shows HT is enabled.

First it was 2.4.20-6smp, but now
2.4.20-24.9smp doesn't show improvement.

Realize errata for 9 will cease in April, but if it isn't too late
really like a possible fix.  Hasn't been tried on Enterprise 3?

Version-Release number of selected component (if applicable):
kernel-2.4.20-24.9smp

How reproducible:
Always

Steps to Reproduce:
1. enable Hyperthreading in BIOS
2. boot up into any linux 9 kernel
3. cat /proc/cpuinfo
    

Actual Results:  In non SMP kernel:  1 processor
In SMP kernel:  2 processors

Expected Results:  In non SMP kernel:  2 processor
In SMP kernel:  4 processors

Additional info:

Customer opened support case number 139877 with ASUS.

Comment 1 Dave Jones 2004-01-15 17:35:11 UTC
The non-SMP kernel will only ever show 1 processor.


Comment 3 Dave Jones 2004-01-15 17:40:32 UTC
duh, brain not in gear. I missed the fact that the SMP kernel was
missing the HT pairs. Hmm. Can we get dmesg output of the SMP kernel ?


Comment 4 Giorel 2004-01-16 16:38:03 UTC
Created attachment 97058 [details]
sysreport bzip, should include dmesg entry

sysreport

Comment 5 Giorel 2004-01-16 16:39:37 UTC
please right click, file was supposed to be sysreport.bz2

Comment 6 Dave Jones 2004-07-12 21:02:26 UTC
end-of-life'd product


Note You need to log in before you can comment on or make changes to this bug.