Bug 113640 - depmod not being run on kernel upgrade to e35 via up2date?
depmod not being run on kernel upgrade to e35 via up2date?
Status: CLOSED DUPLICATE of bug 112914
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 20:51 EST by Rob Kearey
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Kearey 2004-01-15 20:51:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; MSIE 6.999; Windows ME)

Description of problem:
After running a vanilla up2date on a just-kickstarted machine and
installing kernel-2.4.9-e.35 and rebooting, networking did not come
up. Running ifup eth0 brought the message "cannot find module e1000".
Doing a modprobe showed two drivers trying to load:

Jan 16 10:27:30 dhcp-126 kernel: Intel(R) PRO/1000 Network Driver -
version 4.4.12-k1
Jan 16 10:27:30 dhcp-126 kernel: Copyright (c) 1999-2002 Intel
Corporation.
Jan 16 10:27:30 dhcp-126 kernel: eth0: Intel(R) PRO/1000 Network
Connection
Jan 16 10:27:30 dhcp-126 kernel: eth1: Intel(R) PRO/1000 Network
Connection
Jan 16 10:27:30 dhcp-126 ntpdate[644]: can't find host
clock.corp.redhat.com
Jan 16 10:27:30 dhcp-126 kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.20-k1
Jan 16 10:27:30 dhcp-126 ntpdate[644]: no servers can be used, exiting
Jan 16 10:27:30 dhcp-126 kernel: Copyright (c) 1999-2003 Intel
Corporation.
Jan 16 10:27:30 dhcp-126 kernel: Intel(R) PRO/1000 Network Driver -
version 4.4.12-k1
Jan 16 10:27:30 dhcp-126 kernel: Copyright (c) 1999-2002 Intel
Corporation.
Jan 16 10:27:30 dhcp-126 kernel: eth0: Intel(R) PRO/1000 Network
Connection
Jan 16 10:27:30 dhcp-126 kernel: eth1: Intel(R) PRO/1000 Network
Connection
Jan 16 10:27:30 dhcp-126 kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.20-k1

an insmod e1000 brought the following:


3.0
Jan 16 10:29:52 dhcp-126 insmod:
/lib/modules/2.4.9-e.35/kernel/drivers/addon/e1000_5220k1/e1000.o:
init_module: No such device
Jan 16 10:29:52 dhcp-126 insmod: Hint: insmod errors can be caused by
incorrect module parameters, including invalid IO or IRQ parameters
Jan 16 10:29:52 dhcp-126 insmod:
/lib/modules/2.4.9-e.35/kernel/drivers/addon/e1000_5220k1/e1000.o:
insmod eth1 failed
Jan 16 10:29:52 dhcp-126 kernel: Intel(R) PRO/1000 Network Driver -
version 5.2.20-k1
Jan 16 10:29:52 dhcp-126 kernel: Copyright (c) 1999-2003 Intel
Corporation.
Jan 16 10:29:52 dhcp-126 insmod:
/lib/modules/2.4.9-e.35/kernel/drivers/addon/e1000_5220k1/e1000.o:
init_module: No such device
Jan 16 10:29:52 dhcp-126 insmod: Hint: insmod errors can be caused by
incorrect module parameters, including invalid IO or IRQ parameters
Jan 16 10:29:52 dhcp-126 insmod:
/lib/modules/2.4.9-e.35/kernel/drivers/addon/e1000_5220k1/e1000.o:
insmod eth0 failed
Jan 16 10:29:53 dhcp-126 kernel: e1000: eth0 NIC Link is Up 100 Mbps
Full Duplex

Running depmod -a resolved the problem.



Version-Release number of selected component (if applicable):
kernel-2.4.9-e.35

How reproducible:
Always

Steps to Reproduce:
1. Install AS2.1-QU2
2. up2date -u -f
3. reboot - blam, intel modules sick
    

Actual Results:  Networking failed

Expected Results:  Networking should not fail

Additional info:
Comment 3 Suzanne Hillman 2004-02-04 12:57:55 EST

*** This bug has been marked as a duplicate of 112914 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.