Bug 1136443 - Satellite 6 Default Landing Page branding issues: link to product documentation instead of upstream
Summary: Satellite 6 Default Landing Page branding issues: link to product documentati...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat6-branding
TreeView+ depends on / blocked
 
Reported: 2014-09-02 14:57 UTC by sthirugn@redhat.com
Modified: 2019-04-01 20:26 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:44:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Foreman Issue Tracker 7275 None None None 2016-04-22 16:35:09 UTC
Red Hat Bugzilla 1112399 None CLOSED Satellite 6 Default Landing Page branding issues: link to product documentation instead of upstream, and use "Red Hat Sa... 2019-03-27 07:19:34 UTC
Red Hat Bugzilla 1134013 None CLOSED ldap authentication page point to upstream documentation 2019-03-27 07:19:36 UTC

Internal Links: 1112399 1134013

Description sthirugn@redhat.com 2014-09-02 14:57:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
In the default landing page, I still see references to the following foreman links:
http://www.theforeman.org/manuals/1.6/index.html#3.5.5FactsandtheENC
http://projects.theforeman.org/projects/foreman/wiki/External_Nodes
http://www.theforeman.org/manuals/1.6/index.html#3.5.4PuppetReports
http://theforeman.org/projects/foreman/wiki/Puppet_class_browser
http://theforeman.org/projects/foreman/wiki/Howtos


Actual results:


Expected results:


Additional info:
This bug is created while testing/verifying https://bugzilla.redhat.com/show_bug.cgi?id=1112399

Comment 1 sthirugn@redhat.com 2014-09-02 14:57:29 UTC
Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140828.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 2 RHEL Product and Program Management 2014-09-02 15:03:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Stephen Benjamin 2014-10-14 20:15:10 UTC
The entire landing page itself needs to be rewritten, lots of outdated information, not just bad links.

Upstream issue:
http://projects.theforeman.org/issues/7275

Comment 5 Rich Jerrido 2014-10-14 20:25:34 UTC
With regards to input on the landing page, linking the coreSOE guide (https://access.redhat.com/articles/1169613) or the provisioning Guide (https://access.redhat.com/solutions/1201913) will be helpful in getting end-users up and running.

Comment 7 David O'Brien 2015-03-25 01:35:55 UTC
Agree this page needs a rewrite for a variety of reasons. A couple of comments:

I'd prefer to link to the Provisioning Guide on the Portal, or just to the portal, rather than the old Provisioning Guide solution. afaik the solution page should be ready for retirement, and updates should go into the formal Provisioning Guide. Otherwise, we'll end up with duplicate and possibly conflicting info.

Normallly, we avoid linking to or referring paying customers to upstream docs unless absolutely necessary. It would be great if we had placeholders we could use so that as soon as the official docs went live all these links "Just Worked" but I'm not sure if that's something we can depend on.

I can probably do a first pass of revised text.

Comment 9 Tom McKay 2015-04-08 12:11:55 UTC
The Sat6 FAQ would be a good candidate to replace what is there currently.

Comment 10 Stephen Benjamin 2015-04-08 12:28:48 UTC
Or just disabling the welcome page on the dashboard (done in application_controller) would be better, if we can't get some better text in place.

Comment 12 Bryan Kearney 2016-03-17 16:12:49 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 13 Bryan Kearney 2016-03-17 16:12:53 UTC
Upstream bug component is WebUI

Comment 14 Bryan Kearney 2016-03-17 16:12:57 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7275 has been closed
-------------
Anonymous
Applied in changeset commit:313979b97be880a17cc6ad0333893281ae6bc49c.

Comment 15 jcallaha 2016-03-23 17:47:37 UTC
Verified in Satellite 6.2 beta Snap 5. Default landing page, the dashboard, now no longer hosts the links in question.

Comment 18 errata-xmlrpc 2016-07-27 08:44:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.