Bug 1112399 - Satellite 6 Default Landing Page branding issues: link to product documentation instead of upstream, and use "Red Hat Satellite 6" instead of Foreman
Summary: Satellite 6 Default Landing Page branding issues: link to product documentati...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
: 1099797 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker sat6-branding
TreeView+ depends on / blocked
 
Reported: 2014-06-23 20:41 UTC by Xixi
Modified: 2019-09-26 18:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:27:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1099797 None CLOSED Satellite Web UI broken links and branding issues: e.g. manual "Useful template functions and macros" 2019-03-27 07:20:07 UTC
Red Hat Bugzilla 1136443 None CLOSED Satellite 6 Default Landing Page branding issues: link to product documentation instead of upstream 2019-03-27 07:20:07 UTC

Internal Links: 1099797 1136443

Description Xixi 2014-06-23 20:41:19 UTC
Description of problem:
When logging into Satellite Web UI the landing page is displayed first, a couple branding issues on this page:

1) "Foreman" needs to be replaced with "Red Hat Satellite 6" when it refers to the overall product.
For example: "Before you can use Foreman for the first time". "You may operate Foreman in basic mode" etc. (7 occurrences on the page)

2) Links to documentation need to be replaced with product docs instead of upstream. 
For example: "Inventory browser - Importing Puppet Facts" points to http://www.theforeman.org/manuals/1.6/index.html#3.5.5FactsandtheENC 
(lots more links on the page)

Version-Release number of selected component (if applicable):
6.0.3 (Satellite 6.0 Beta RC)

How reproducible:
always

Steps to Reproduce:
1. log into Satellite 6.0 Beta web UI
2.
3.

Actual results:
(see above)

Expected results:
branding fixes (see above)

Additional info:

Comment 1 Xixi 2014-06-23 20:43:02 UTC
Full text from the current landing page: 

"Welcome
 

Before you can use Foreman for the first time there are a few tasks that must be performed. You must decide how you wish to use the software, and update the primary settings file config/settings.yaml and the settings to indicate your selections.
Operating Mode

You may operate Foreman in basic mode, in which it acts as a reporting and external node classifier or you may also turn on unattended mode operation in which Foreman creates and manages the configuration files necessary to completely configure a new host. When operating in unattended mode Foreman will require more information, so expect more questions, but it will be able to automate host installations for Red Hat, Debian, SUSE and Solaris operating systems (and their clones), see here for more details.
Create a Capsule

If you're planning to do anything more than just handle reports, you'll be in need of a smart proxy - either on this machine or elsewhere on your network. You can find details of how to set up the proxy at Smart-Proxy Installation.

Important Once installed you should head over to Capsules to point Foreman at it.

User Authentication

Foreman, by default, operates in anonymous mode where all operations are performed without reference to the user who is performing the task. If you wish to track the actions of a particular user then it is possible to use an additional authentication stage and provide a user account. At present, authentication is performed against the internal Database or a LDAP service provided by one or more LDAP servers.

Additionally, you may restrict user permissions based on many criteria, make sure you check the roles settings tab.

    For internal Users, simply create a new user at the Users page
    If you chose to use LDAP authentication then you must provide connection details for your authentication provider on LDAP page
    For Roles and permissions, see the Roles page

Import your data

Foreman comes with some importers to ease the burden of entering loads of data about your current installation. If you are already using puppet you should consider using some of the rake tasks that have been provided.

    Inventory browser - Importing Puppet Facts
    Puppet External Nodes - Importing Puppet classes and environments
    Reporting - Puppet Reports integration

Additional steps

You may optionally wish to generate the online documentation for your puppet classes - puppet class browser.

After you have decided on the two primary modes of operation and performed any appropriate imports then it would be good idea if you visited some of the other configuration pages to see if additional setup is required under the Additional settings select box on the top right.

You may also find the Howtos useful.

Notice This page will self destruct once Foreman starts to receive data about your hosts. You can view this information again by clicking on the "First use instructions" link on the about page."

Comment 3 RHEL Product and Program Management 2014-06-23 21:06:45 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 7 sthirugn@redhat.com 2014-09-02 14:27:22 UTC
Failed.

- Issue 1 mentioned in the bug is looking good now (all foreman naming replaced with sat6)

- Issue 2 mentioned in the bug is still existing. I still see references to the following foreman links:
http://www.theforeman.org/manuals/1.6/index.html#3.5.5FactsandtheENC
http://projects.theforeman.org/projects/foreman/wiki/External_Nodes
http://www.theforeman.org/manuals/1.6/index.html#3.5.4PuppetReports
http://theforeman.org/projects/foreman/wiki/Puppet_class_browser
http://theforeman.org/projects/foreman/wiki/Howtos


Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140828.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 8 sthirugn@redhat.com 2014-09-02 14:58:15 UTC
Verified as per Comment 7.  A new bug is created to track issue 2 - https://bugzilla.redhat.com/show_bug.cgi?id=1136443

Comment 9 Dominic Cleal 2014-09-03 08:31:19 UTC
*** Bug 1099797 has been marked as a duplicate of this bug. ***

Comment 10 Bryan Kearney 2014-09-11 12:27:04 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.