Bug 113697 - Author steps after finish and adding comment go to categorisation step
Author steps after finish and adding comment go to categorisation step
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS-usability (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
http://aplaws-ws3.ccm-demo.redhat.de/...
:
: 113701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 11:41 EST by Lindsay Ould
Modified: 2010-09-03 10:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 10:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lindsay Ould 2004-01-16 11:41:31 EST
Description of problem:logged on as author - create new article - 
finish authoring steps, after selecting finish and adding comment 
categorisation step is displayed.


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.logon as user
2.create new article
3.finish authoring step - add comment and select finish
  
Actual results:


Expected results:
Expect to be returned to /content-center

Additional info:
Comment 1 Scott Seago 2004-01-16 11:45:12 EST
Currently upon completing a task, the author is left on the original
page, as post-task redirection may be a bit complex. It's hard to know
whether the author would want to go back to content center, go to the
browse pane, or stay on the current page. The only current exception
to this is  if the author has an active deploy task on the same item
(true for rapid workflow), in which case the author is redirected to
the lifecycle tab.
Comment 2 Scott Seago 2004-01-16 16:33:31 EST
Apparently this functionality was already agreed to be out-of-scope
for this release.
Comment 3 Scott Seago 2004-01-16 16:34:33 EST
*** Bug 113701 has been marked as a duplicate of this bug. ***
Comment 4 Lindsay Ould 2004-01-19 06:23:18 EST
Scott - Your e-mail of 17/1 states that this item is out of scope.  
As it stands, when you finish authoring, you are taken into an open 
assign categories form which does not make sense.  If you have just 
finished a task on that item, you do not want to go back into one 
step on that item either. - We need to at least return the user to a 
neutral place - in my view, that is /content-centre
Comment 5 Scott Seago 2004-01-19 09:20:02 EST
The problem is that the proper "neutral place" may be different to
different users. Since there's no one obvious appropriate place, the
current behavior is to leave the user in the current location. If
you're on the categories screen when you say 'finish', then you stay
there. If you're on the metadata step, then that's where you stay.

It was listed as out-of-scope since the requirements didn't address
it, and at the time there did not seem to be a trivial solution, since
the global redirect may not be universally appropriate. I'll speak
with Dan and Brian to see if there may be some quick but more
appropriate solution, but I'm not sure what we'll be able to do here.
Comment 6 Scott Seago 2004-01-19 15:47:58 EST
OK, we've decided to implement this as an optional feature, tied to
the "streamlined creation" parameter. So the same parameter that turns
on the automatic opening of basic properties and body text steps and
forwarding from one authoring step to the next controls the redirect.
When streamlined creation is set to true, then the user is redirected
to /content-center after entering workflow comments. The only
exception to this is if the next step is deploy _and_ the commenting
user also has this assigned. THe use case here is the two-step rapid
workflow will go immediately from 'finish authoring' form to the
publish form.
Comment 7 David Lawrence 2006-07-17 23:54:22 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.