Bug 113701 - Approval step by Editor ends with editing screen with no permissions
Approval step by Editor ends with editing screen with no permissions
Status: CLOSED DUPLICATE of bug 113697
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS-usability (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
http://aplaws-ws3.ccm-demo.redhat.de/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 12:28 EST by Lindsay Ould
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lindsay Ould 2004-01-16 12:28:08 EST
Description of problem:logged on as editor to approve content in 
list - previewed item - then selected finish - returns user to 
authoring step with no permissions 

http://aplaws-ws3.ccm-demo.redhat.de/ccm/content/admin/item.jsp?
bbp.904.sel=223&bbp.1587.sel=235&item_id=886&bbp.4530.d=asc&bbp.2020.s
el=254&bbp.229.sel=206&bbp.3379.sel=272&g11n.enc=UTF-
8&bbp.1806.sel=248&bbp.i=d0.4.2.a.1.5d.1.m.1.7t.1.4a.1.60.1.4w.1.e0.1.
62.1.5w.1.8k.1.e8.1.5o.1.4v.1.4c.1.5s.1.55.1.23.1.68.1&bbp.33.sel=201&
bbp.688.sel=217&bbp.3587.sel=284&bbp.2841.sel=278&bbp.3.pane=1&bbp.377
1.sel=402&bbp.220.col=2&bbp.4543.d=asc&bbp.3045.sel=289&bbp.4073.sel=1
97&bbp.2328.sel=261&bbp.3220.sel=268&bbp.531.sel=213&bbp.3850.sel=191&
bbp.1082.sel=228&bbp.4236.d=asc


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1.logon as editor
2.select item to approve
3.select preview
4.select finish
5.add comment select approve radio button
6.select finish
7.view screen  
Actual results:


Expected results:
Expect to return to user task list (/content-center)


Additional info:
Comment 1 Scott Seago 2004-01-16 16:34:30 EST
Duplicate of 113697 -- same issue, just reported under a different
workflow task.

*** This bug has been marked as a duplicate of 113697 ***
Comment 2 Lindsay Ould 2004-01-19 06:29:45 EST
Scott - You state above that this is a duplicate of 113697. At 
present finishing the task on these takes you to two different 
places - authoring takes you to an open assign categories form and 
editing takes you to an authoring form with no permissions.  Ideally 
once you have added an optional comment and clicked on approve for 
editing step, all users should be redirected to /content-centre but 
if this is not possible, at least both actions should be consistent 
and return to an authoring page, even though the authors cannot do 
any editing as items are not locked to them. - We need to resolve 
this 
Comment 3 Scott Seago 2004-01-19 09:17:13 EST
I'll look into this in more detail when I get into the office, but I
_think_ that both cases do the exact same thing: after finishing a
step, you remain on the same page you were. If you still have
permissions to edit, you get the edit links, etc. If you no longer
have permission to edit, then the permissions links are not there. In
the author's case, you were on the categorization step before clicking
"finish authoring" In the editor's case, you were probably on the
basic properties step, so  that's where you remain.

The problem with the redirect to /content-center is that it is not a
universal requirement. To make the change would be more complex, as
we'd have to include some configuration scheme as to what happens
after authoring, since there are several possibilities, only one of
which is the /content-center redirect. Other sites may well want a
different action.
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.