Bug 1136985 - theme must be updated for GTK+ 'checked' state (not 'active') for checkboxes
Summary: theme must be updated for GTK+ 'checked' state (not 'active') for checkboxes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: oxygen-gtk3
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1133189 1133191 (view as bug list)
Depends On:
Blocks: F21AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2014-09-03 18:48 UTC by Adam Williamson
Modified: 2014-09-12 03:50 UTC (History)
6 users (show)

Fixed In Version: oxygen-gtk3-1.4.0-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-12 03:50:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2014-09-03 18:48:03 UTC
GTK+ made a change to checkboxes, which makes 'checked' ones not show up properly unless themes update their behaviour. I believe:

https://projects.kde.org/projects/playground/artwork/oxygen-gtk/repository/revisions/5f97a2d3f8880eb68ce2e0fd44285b6adc38293e

fixes this upstream, and we just need to pull that back downstream. However, this affects the appearance of anaconda during installation from KDE media, so we may want to pull it into F21 Alpha.

Comment 1 Fedora Update System 2014-09-03 19:15:39 UTC
oxygen-gtk3-1.4.0-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/oxygen-gtk3-1.4.0-4.fc21

Comment 2 Rex Dieter 2014-09-03 19:38:04 UTC
*** Bug 1133189 has been marked as a duplicate of this bug. ***

Comment 3 Rex Dieter 2014-09-04 16:00:15 UTC
*** Bug 1133191 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-09-06 00:58:51 UTC
Package oxygen-gtk3-1.4.0-4.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing oxygen-gtk3-1.4.0-4.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10178/oxygen-gtk3-1.4.0-4.fc21
then log in and leave karma (feedback).

Comment 5 Mike Ruckman 2014-09-06 18:10:49 UTC
Confirmed this fix by updating oxygen-gtk3 before running liveinst. However it wasn't pulled into the TC6 compose, so there may be more reports of it going forward until the next TC.

Comment 6 Adam Williamson 2014-09-10 18:02:37 UTC
Discussed at 2014-09-10 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-10/f21-blocker-review.2014-09-10-16.07.log.txt . Accepted as a freeze exception issue, obviously we want the KDE live installer to not have invisible checkboxes.

Comment 7 Fedora Update System 2014-09-12 03:50:02 UTC
oxygen-gtk3-1.4.0-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.