Bug 1138126 - [ImportDomain] Engine should add a CDA validation when trying to attach an imported Storage Domain to an un-initalized Data Center
Summary: [ImportDomain] Engine should add a CDA validation when trying to attach an im...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Maor
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On:
Blocks: 1178646
TreeView+ depends on / blocked
 
Reported: 2014-09-04 06:39 UTC by Maor
Modified: 2019-05-20 11:18 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when trying to attach an imported storage domain that carried existing metadata to an uninitialized data center, an exception from VDSM was returned with no proper warning message. With this update, the storage domain is checked for existing metadata and an error message is provided to advise users to attach a clean storage domain first.
Clone Of:
: 1178646 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:39:37 UTC
oVirt Team: Storage
amureini: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 34239 master ABANDONED core: Add a CDA on attach to an uninitialized Data Center Never
oVirt gerrit 35226 master ABANDONED webadmin: Add a warning when importing a Storage Domain Never
oVirt gerrit 36454 master MERGED core: Add a CDA on attach to an uninitialized Data Center Never
oVirt gerrit 36546 ovirt-engine-3.5 MERGED core: Add a CDA on attach to an uninitialized Data Center Never

Description Maor 2014-09-04 06:39:27 UTC
Description of problem:
Engine should add a CDA validation when trying to attach an imported Storage Domain to an un-initalized Data Center, since as part of the attach process it also use detach

Currently, VDSM take a lock on the storage pool when performing a detach operation, this obstacle should be removed in a later version, once the storage pool will be removed completely in VDSM.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Try to attach an imported Storage Domain to an uninitialized Data Center
2.
3.

Actual results:
The domain will fail to be attached

Expected results:
A proper CDA message should be present to the user

Additional info:

Comment 1 Allon Mureinik 2014-11-26 17:16:37 UTC
Once the domain is attached, there's no indication in the DB where it came from - we need to query the /storage/ in order to do this.
Pushing out to 3.6.0

Comment 3 Ori Gofen 2015-04-19 11:58:37 UTC
Verified on oVirt3.6.1 master

Comment 6 errata-xmlrpc 2016-03-09 20:39:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.