Bug 113858 - Add syslog-ng (as a replacement or an alternative to sysklogd).
Add syslog-ng (as a replacement or an alternative to sysklogd).
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.balabit.com/products/syslo...
: FutureFeature
: 91658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-19 11:12 EST by Péter, Soós
Modified: 2014-03-16 22:41 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 13:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog-ng.conf with similar functionality as syslogd.conf (2.63 KB, text/plain)
2004-01-19 11:15 EST, Péter, Soós
no flags Details
syslog-ng rpm (391.90 KB, application/x-rpm)
2005-02-22 07:54 EST, Péter, Soós
no flags Details

  None (edit)
Description Péter, Soós 2004-01-19 11:12:04 EST
Description of problem:
syslogd able to logging only by facility and severity, but not by
host, message content, date, etc. and unable to log via TCP, forward
logs etc.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Try to forward logs via tcp keeping the host name and logging into
separate files by hosts using syslogd.

    

Additional info:
syslog-ng is the next generation of the syslog daemon. syslog-ng gives
you the flexibility of logging not only by facility and severity, but
also by host, message content, date, etc. It can also replace klogd's
function of logging kernel messages. It is under GPL.
Comment 1 Péter, Soós 2004-01-19 11:15:50 EST
Created attachment 97101 [details]
syslog-ng.conf with similar functionality as syslogd.conf
Comment 2 Bill Nottingham 2004-01-19 12:10:46 EST
Adding it via alternatives isn't going to happen. It will either be
added as a replacement, or it won't be added.
Comment 3 Péter, Soós 2004-02-09 06:05:55 EST
What is the way to add it as replacement? I use it for years instead
of sysklogd package.
Comment 4 Seth Vidal 2004-05-01 04:04:11 EDT
nice syslog-ng packages  are in fedora.us for fc1 and fc2 if I
remember correctly.

check fedora.us bugzilla for packages on QA
Comment 5 Jason Vas Dias 2004-08-20 16:30:50 EDT
Users are free to replace whatever RedHat Linux component they want to.
But I don't think we should force all users to learn a new syslog.conf
configuration syntax, nor replace a fundamental component of the
operating system with relatively untried and untested software,
when syslogd does all that 99% of users need it to do.
Comment 6 Seth Vidal 2004-08-20 16:34:52 EDT
syslogd hasn't been maintained in years and iirc fedora is SUPPOSED to
be for new stuff. Oh and I'm curious, when did you get appointed the
determining body in inclusion or exclusion of packages in fedora?


Comment 7 nathan r. hruby 2004-08-20 17:12:01 EDT
Oh god.  Please no! The questions from my users will never ever ever
end.  

If you want a nicer syslog daemon, how about metalog[1] or at least
something with a config sytax that doesn't requre a PhD in Physics to
understand?

[1] - http://metalog.sourceforge.net/

-n
Comment 8 Stephen John Smoogen 2004-08-20 17:17:31 EDT
We replace syslogd with syslog-ng on most of our servers. We need its
capabilities for our environment. However it would be nice to have an
official version with large file support etc enabled.
Comment 9 Jason Vas Dias 2004-08-20 17:57:18 EDT
 syslog-ng will not be replacing syslog (for reasons indicated by
 comment #7, and others) .
 RE: comment #6: I'm the sysklogd maintainer at RedHat, and it is
 being maintained (new version 2004-08-02: sysklogd-1.4.1-22) .
 
 I will see about getting syslog-ng and metalog onto the standard
 fedora build, but neither will replace sysklogd (they won't be
 installed by default). Both are relatively untested (compared to
 syslog), require users to learn new syslog.conf syntax, and aren't
 necessary - for 99% of users, syslog is just fine. 
 
Comment 10 Alan Cox 2004-08-20 20:29:39 EDT
There is another problem that has to be solved at the same time -
locale data needs to be handled and either character conversion or
locale tagged messages (or both).

syslog is not fine for most non americans, its merely bearable.
Unfortunately the fixing is going to involve both syslog and libc side
stuff I understand.
Comment 11 Seth Vidal 2004-08-20 20:48:38 EDT
Why all the finality on this subject? You do realize fedora is
intended to be an community project, right? Why not engage in
discussion on the subject.

1. most users don't know syslog.conf syntax at all, they use the
defaults the system ships with
2. how much testing have you done with syslog-ng? I've been using it
for > 200 system network all logging to a central location for more
than 4 years. Is that enough testing?
3. So to be clear, since you're the syslog maintainer at red hat that
means you have final and unwaivering authority on the subject?

Reopened.
Comment 12 Jason Vas Dias 2004-08-23 10:48:20 EDT
RE: comment #10: 
    syslogd DOES log unicode characters fine . The point is, it should
    NOT be doing ANY character conversion - once that was removed
    (bug 89292) UTF-8 characters were logged correctly - if you find
    that not to be the case, please raise another bug on the subject.

RE: comment #11:
    As I said in comment #9, I will be building both syslog-ng and
    metalog and putting them on the Fedora CD - users can choose to
    install them if they wish.
    > I've been using it for > 200 system network all logging to a 
    > central location for more than 4 years. Is that enough testing?
    NO - syslogd has been in use on millions of machines since at 
        least 1983 .
    We also have requests for metalog . Users have responded
    to both this bug and the metalog bug requests with 
    "No - please don't replace syslogd" .
    It will be up to users whether they want to replace syslogd with
    syslog-ng or metalog, and I'll enable that choice by putting both
    metalog and syslog-ng in the Fedora build.
Comment 13 Bill Nottingham 2004-08-23 17:15:26 EDT
Gack, no.

One syslog daemon in core... more than that is just excessive.
Comment 14 acount closed by user 2004-08-26 21:43:28 EDT
*** Bug 91658 has been marked as a duplicate of this bug. ***
Comment 15 Aleksey Nogin 2004-08-26 23:03:29 EDT
Resolution:   NOTABUG? I can understand "WONTFIX", but this is a valid
RFE that does not seem to warrant "NOTABUG"...
Comment 18 Terje Bless 2005-02-22 04:20:58 EST
So has a (RHEL-compatible?) syslog-ng hit Fedora yet? I can't seem to find it...
Comment 19 Péter, Soós 2005-02-22 07:54:32 EST
Created attachment 111292 [details]
syslog-ng rpm

Here is my syslog-ng source rpm for Fedora 2.

Note You need to log in before you can comment on or make changes to this bug.