Bug 1138604 - libvirt qemu:///session URLs don't work: libvirt: XML-RPC error : Failed to connect socket to '/builddir/.cache/libvirt/libvirt-sock': No such file or directory
Summary: libvirt qemu:///session URLs don't work: libvirt: XML-RPC error : Failed to c...
Keywords:
Status: CLOSED DUPLICATE of bug 927369
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1140624 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1021149
TreeView+ depends on / blocked
 
Reported: 2014-09-05 09:52 UTC by Richard W.M. Jones
Modified: 2014-09-16 11:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-16 11:41:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-09-05 09:52:08 UTC
Description of problem:

libvirt qemu:///session URLs are broken.  See the end of the build
log here:

http://download.devel.redhat.com/brewroot/work/tasks/2686/7922686/build.log

libvirt: XML-RPC error : Failed to connect socket to '/builddir/.cache/libvirt/libvirt-sock': No such file or directory
libguestfs: error: could not connect to libvirt (URI = qemu:///session): Failed to connect socket to '/builddir/.cache/libvirt/libvirt-sock': No such file or directory [code=38 domain=7]

Version-Release number of selected component (if applicable):

libvirt-devel-1.2.8-1.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Build libguestfs and run 'make quickcheck'

Comment 2 Richard W.M. Jones 2014-09-05 11:19:44 UTC
I'm able to reproduce this using:

rm -rf /tmp/p
mkdir -p /tmp/p/.cache
killall libvirtd
export LIBVIRT_DEBUG=1
export HOME=/tmp/p
export XDG_RUNTIME_DIR=/tmp/p/.cache
libguestfs-test-tool

Note that /tmp/p/.cache/libvirt does not exist in this scenario.
I would have expected libvirt to create the directory if it does
not exist, but apparently it does not.

(You get the same error if /tmp/p/.cache doesn't exist too)

Downgrading to libvirt 1.1.1-29.el7 fixes the problem, therefore this
seems to be a regression between releases.

Comment 4 Jiri Denemark 2014-09-05 14:32:47 UTC
Hmm, looks like another regression caused by the socket activation code. The socket is no longer created by libvirtd but it's created by the client and passed to the daemon as a file descriptor.

Comment 5 Richard W.M. Jones 2014-09-05 20:11:21 UTC
FYI same thing is now happening in Rawhide, eg:

https://kojipkgs.fedoraproject.org//work/tasks/2029/7532029/build.log

Comment 6 Martin Kletzander 2014-09-08 05:48:42 UTC
Fix proposed upstream:

https://www.redhat.com/archives/libvir-list/2014-September/msg00374.html

Comment 7 Jiri Denemark 2014-09-12 06:52:39 UTC
*** Bug 1140624 has been marked as a duplicate of this bug. ***

Comment 8 Martin Kletzander 2014-09-16 11:41:20 UTC
I can confirm this is a dup of Bug 927369, the issue is beaing dealt with in there (since it cause it as well).

*** This bug has been marked as a duplicate of bug 927369 ***


Note You need to log in before you can comment on or make changes to this bug.