Bug 1139260 - [RFE] Lost link between host and content-host
Summary: [RFE] Lost link between host and content-host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-08 13:36 UTC by Pavel Studeník
Modified: 2019-09-26 17:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:11:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
host is available under content-hosts (70.62 KB, image/png)
2016-04-15 09:23 UTC, Sachin Ghai
no flags Details
host is available under all hosts and details page shows a new tab 'content' that provides the linking (59.58 KB, image/png)
2016-04-15 09:25 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 9380 None None None 2016-04-22 14:57:48 UTC

Description Pavel Studeník 2014-09-08 13:36:00 UTC
Description of problem:
I registered system to satellite 6 by subscription-manager and then I created new host by puppet (existed host). If I look at page with detail of host I can see only:

Properties
=====================================
Subscription status: 	Not available 

But system is subscribed.

Version-Release number of selected component (if applicable):
Version 6.0.4

How reproducible:
always

Steps to Reproduce:
1. register system as content-host (subscription-manager register ...)
2. create new host by puppet (puppet client)
3. try to find link between host and content-host

Actual results:
without correct connection between katello and foreman

Expected results:
detail of content-host and host are linked

Comment 1 RHEL Product and Program Management 2014-09-08 13:43:28 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Pavel Studeník 2014-09-09 16:56:40 UTC
At first I created new host by puppet, then I registered system as content-host (by subscription-manager) and links exist on detail pages.

But If I make it the other way around, then detail pages are without links. Order of steps is important.

1. subscription-manager register ...
2. create new host by puppet agent
3. check details of host and content-host

Comment 4 Brad Buckingham 2014-12-09 20:35:51 UTC
This one is similar to bug 1100284.

Comment 5 Tom McKay 2015-02-13 20:41:21 UTC
Created redmine issue http://projects.theforeman.org/issues/9380 from this bug

Comment 6 Bryan Kearney 2015-08-25 18:07:33 UTC
Upstream bug component is Content Management

Comment 7 Bryan Kearney 2016-02-05 20:34:04 UTC
Upstream bug component is Content Management

Comment 8 Brad Buckingham 2016-03-07 15:49:43 UTC
Satellite 6.2 includes a feature referred to as 'host unification'.  With that feature, this behavior should no longer occur. 

Moving bug to ON_QA for verification.

Comment 10 Sachin Ghai 2016-04-15 09:21:29 UTC
Verified sat6.2 beta snap8.1

The reported issue has been addressed as part if host unification feature. When you register a host via subscription-manager, the registered host entry populated under contents host as well as under all hosts.

here how I registered a host

cloud-qe-12.idmqe. ~]# subscription-manager register --activationkey ak_rhel7 --org Default_Organization
The system has been registered with ID: d5ea9cb7-35be-48b1-9a48-3571476ec63e 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Not Subscribed

Unable to find available subscriptions for all your installed products.


In webUI, this host is available under contents host as well as under all hosts and both are linked.

Comment 11 Sachin Ghai 2016-04-15 09:23:44 UTC
Created attachment 1147557 [details]
host is available under content-hosts

Comment 12 Sachin Ghai 2016-04-15 09:25:04 UTC
Created attachment 1147558 [details]
host is available under all hosts and details page shows a new tab 'content' that provides the linking

Comment 14 errata-xmlrpc 2016-07-27 09:11:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.