Bug 1139357 - qemu doesn't exit when system powers down
Summary: qemu doesn't exit when system powers down
Keywords:
Status: CLOSED DUPLICATE of bug 1139387
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1139380
TreeView+ depends on / blocked
 
Reported: 2014-09-08 18:03 UTC by Stef Walter
Modified: 2014-09-15 11:03 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 19:52:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Stef Walter 2014-09-08 18:03:41 UTC
Description of problem:

The qemu process does not stop when the system powers down. The process simply sits there.

Version-Release number of selected component (if applicable):

$ rpm -q qemu-kvm
qemu-kvm-2.1.0-4.fc21.x86_64

How reproducible:

Every time.


Steps to Reproduce:

 * Download images
$ mkdir test
$ cd test
$ wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-root.xz
$ wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-initrd.xz
$ wget wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-kernel.xz
$ xz -d *.xz

 * Run the system
$ /usr/bin/qemu-system-x86_64 -machine accel=kvm -m 1024 -drive if=virtio,file=$PWD/cockpit-fedora-20-x86_64-root,index=0,serial=ROOT,snapshot=on -kernel $PWD/cockpit-fedora-20-x86_64-kernel -initrd $PWD/cockpit-fedora-20-x86_64-initrd -append "root=/dev/vda console=ttyS0 quiet enforcing=0" -nographic -monitor unix:path=$PWD/cockpit.mon,server,nowait

 * log into the system using root password 'foobar'
 * type the command in the VM:
# poweroff

Actual results:

The qemu-system-x86_64 process never exits.

Expected results:

The qemu-system-x86_64 process exits like it did in qemu 1.6.x. The exit code should be zero.

Additional info:

The above test case works well on Fedora 20 with identical images, with qemu-1.6.2-7 and similar.

Comment 1 Richard W.M. Jones 2014-09-09 07:46:27 UTC
How is this bug different from bug 1139387?

Comment 2 Stef Walter 2014-09-09 08:14:38 UTC
To me they seem to be separate bugs, but you may know better. 

This bug doesn't involve an ACPI button press, whereas bug #1139387 does have to do with ACPI. 

(even) When the VM itself does the poweroff, shuts down, and halts, qemu doesn't exit.

Comment 3 Cole Robinson 2014-09-11 19:52:41 UTC
They seem to be the same root issue, so duping

*** This bug has been marked as a duplicate of bug 1139387 ***

Comment 4 Stef Walter 2014-09-15 11:03:39 UTC
Confirming duplicate. Fix on duplicate fixes this symptom as well.


Note You need to log in before you can comment on or make changes to this bug.