Bug 1139387 - system_powerdown has no effect in qemu 2.1.x
Summary: system_powerdown has no effect in qemu 2.1.x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1139357 (view as bug list)
Depends On:
Blocks: 1139380
TreeView+ depends on / blocked
 
Reported: 2014-09-08 19:47 UTC by Stef Walter
Modified: 2014-09-23 05:07 UTC (History)
10 users (show)

Fixed In Version: qemu-2.1.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 05:07:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Stef Walter 2014-09-08 19:47:57 UTC
Description of problem:

The qemu monitor system_powerdown command no longer has any effect in qemu 2.1 in Fedora 21.

Version-Release number of selected component (if applicable):

qemu-2.1.0-4.fc21.x86_64

How reproducible:

Every time

Steps to Reproduce:

 * Download images
$ mkdir test
$ cd test
$ wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-root.xz
$ wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-initrd.xz
$ wget wget http://files.cockpit-project.org/testdata/images/cockpit-fedora-20-x86_64-kernel.xz
$ xz -d *.xz

 * Run the system
$ /usr/bin/qemu-system-x86_64 -machine accel=kvm -m 1024 -drive if=virtio,file=$PWD/cockpit-fedora-20-x86_64-root,index=0,serial=ROOT,snapshot=on -kernel $PWD/cockpit-fedora-20-x86_64-kernel -initrd $PWD/cockpit-fedora-20-x86_64-initrd -append "root=/dev/vda console=ttyS0 quiet enforcing=0" -nographic -monitor unix:path=$PWD/cockpit.mon,server,nowait

 * Wait for the VM to boot
 * In another terminal, run the system_powerdown command in the qemu monitor:
$ cd test
$ nc -U cockpit.mon
QEMU 2.1.0 monitor - type 'help' for more information
(qemu) system_powerdown

Actual results:

No effect on the running VM.

Expected results:

The VM shuld proceed to shutdown (as if an ACPI power button had been pressed). This happened in qemu 1.6.x. The exit code should be zero.

Additional info:

The above test case works well on Fedora 20 with identical images, with qemu-1.6.2-7 and similar.

Comment 1 Cole Robinson 2014-09-11 19:52:41 UTC
*** Bug 1139357 has been marked as a duplicate of this bug. ***

Comment 2 Cole Robinson 2014-09-11 19:54:39 UTC
I reproduced the issue with 2.1.0 packages in f21, but the issue seems fixed with 2.1.1 stable which I'm building now.

Comment 3 Fedora Update System 2014-09-11 22:22:18 UTC
qemu-2.1.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qemu-2.1.1-1.fc21

Comment 4 Fedora Update System 2014-09-12 17:46:56 UTC
Package qemu-2.1.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-2.1.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10761/qemu-2.1.1-1.fc21
then log in and leave karma (feedback).

Comment 5 Stef Walter 2014-09-15 11:03:11 UTC
This fixes the issue with the cockpit integration tests.

Comment 6 Fedora Update System 2014-09-23 05:07:37 UTC
qemu-2.1.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.