Bug 1139767 - order in bundle recipe does not affect deployment order
Summary: order in bundle recipe does not affect deployment order
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER03
: JON 3.3.0
Assignee: Thomas Segismont
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Depends On:
Blocks: 1050014
TreeView+ depends on / blocked
 
Reported: 2014-09-09 15:14 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:01:10 UTC
Type: Bug


Attachments (Terms of Use)
deploy.xml (1.10 KB, text/plain)
2014-09-09 15:14 UTC, Armine Hovsepyan
no flags Details
application1 (4.36 KB, application/octet-stream)
2014-09-09 15:15 UTC, Armine Hovsepyan
no flags Details
application2 (4.36 KB, application/octet-stream)
2014-09-09 15:15 UTC, Armine Hovsepyan
no flags Details
script.cli (3 bytes, text/plain)
2014-09-09 15:15 UTC, Armine Hovsepyan
no flags Details
recipe2 (1.10 KB, text/plain)
2014-09-09 15:16 UTC, Armine Hovsepyan
no flags Details
order1 (182.99 KB, application/octet-stream)
2014-09-18 13:47 UTC, Armine Hovsepyan
no flags Details
order2 (167.94 KB, application/octet-stream)
2014-09-18 13:48 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-09-09 15:14:50 UTC
Created attachment 935786 [details]
deploy.xml

Description of problem:
order in bundle recipe does not affect deployment order

Version-Release number of selected component (if applicable):
JON 3.3 ER02

How reproducible:
always

Steps to Reproduce:
1. upload bundle recipe with order 1. script 2. application.war
2. upload corresponding script and application.war and deploy on domain server
3. upload bundle recipe with order 1.  application.war  2. script
4. upload corresponding script and application.war and deploy on domain server


Actual results:
order of deployment is the same after step2 and step 4

Expected results:
order of deployment should be as lines in recipe xml

Additional info:
both recipe files, script and application wars attached
screen-shot of deployment in UI attached

Comment 1 Armine Hovsepyan 2014-09-09 15:15:10 UTC
Created attachment 935787 [details]
application1

Comment 2 Armine Hovsepyan 2014-09-09 15:15:26 UTC
Created attachment 935788 [details]
application2

Comment 3 Armine Hovsepyan 2014-09-09 15:15:47 UTC
Created attachment 935789 [details]
script.cli

Comment 4 Armine Hovsepyan 2014-09-09 15:16:37 UTC
Created attachment 935790 [details]
recipe2

Comment 5 Thomas Segismont 2014-09-11 20:05:37 UTC
Armine, I tried on my box and could not reproduce. Could you please point me at your testing environment? I'd like to do some debugging.

Comment 7 Thomas Segismont 2014-09-12 09:52:32 UTC
I'm not able to reproduce on my box nor on your testing environment. Moving to MODIFIED, ER03 so this case gets retested with the next build.

Comment 8 Simeon Pinder 2014-09-17 02:49:37 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149

Comment 9 Armine Hovsepyan 2014-09-18 13:47:09 UTC
verified in JON 3.3 ER03

screen-shots attached

Thank you!

Comment 10 Armine Hovsepyan 2014-09-18 13:47:39 UTC
Created attachment 938915 [details]
order1

Comment 11 Armine Hovsepyan 2014-09-18 13:48:00 UTC
Created attachment 938916 [details]
order2


Note You need to log in before you can comment on or make changes to this bug.