Bug 1139793 - [RFE] Keep hosted engine VM configuration in the shared storage
Summary: [RFE] Keep hosted engine VM configuration in the shared storage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Simone Tiraboschi
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1269768
Blocks: 1139795 1167262 1234915
TreeView+ depends on / blocked
 
Reported: 2014-09-09 15:59 UTC by Doron Fediuck
Modified: 2016-03-09 18:52 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, every host in a self-hosted engine environment stored a configuration file for the self-hosted engine virtual machine. As a result, any change to the configuration required users to update the file on each host. Now, a single self-hosted engine configuration file is saved on shared storage, and can be accessed by all hosts.
Clone Of:
: 1139795 (view as bug list)
Environment:
Last Closed: 2016-03-09 18:52:12 UTC
oVirt Team: Integration
Target Upstream Version:
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1139795 unspecified CLOSED [RFE] Keep hosted engine VM configuration in the shared storage 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHEA-2016:0375 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2016-03-09 23:48:34 UTC
oVirt gerrit 42052 master MERGED packaging: setup: saving the configuration on the shared domain Never
oVirt gerrit 42209 None None None Never
oVirt gerrit 42233 None None None Never
oVirt gerrit 42234 None None None Never
oVirt gerrit 42389 None None None Never
oVirt gerrit 44542 master MERGED Tool to convert OVF to VDSM create VM parameters 2016-01-05 08:45:23 UTC
oVirt gerrit 51355 ovirt-hosted-engine-ha-1.3 MERGED Tool to convert OVF to VDSM create VM parameters 2016-01-05 10:28:40 UTC

Internal Links: 1139795

Description Doron Fediuck 2014-09-09 15:59:40 UTC
Description of problem:
Currently every host has a configuration file for the hosted engine VM.
If a change is needed files in all hosts should be fixed.

So we should be storing a single file in a shared storage to simplify it.

Comment 1 Nikolai Sednev 2015-04-28 14:25:31 UTC
(In reply to Doron Fediuck from comment #0)
> Description of problem:
> Currently every host has a configuration file for the hosted engine VM.
> If a change is needed files in all hosts should be fixed.
> 
> So we should be storing a single file in a shared storage to simplify it.

Hi Doron,
Should this require from us to use shared storage at all times for HE, thus turning shared storage to basic requirement for the deployment?

Comment 2 Roy Golan 2015-05-06 07:51:33 UTC
(In reply to Nikolai Sednev from comment #1)
> (In reply to Doron Fediuck from comment #0)
> > Description of problem:
> > Currently every host has a configuration file for the hosted engine VM.
> > If a change is needed files in all hosts should be fixed.
> > 
> > So we should be storing a single file in a shared storage to simplify it.
> 
> Hi Doron,
> Should this require from us to use shared storage at all times for HE, thus
> turning shared storage to basic requirement for the deployment?

the requirement already exist today: we create a DC, domain and disks for the
engine-vm. NFS,glusgter,iscsi, we see them all as non-local.

our goal is to alleviate ovirt's backup of vms in special disks for shared configuration for both the VM and the broker conf

Comment 5 Elad 2016-01-26 08:56:20 UTC
Hosted engine VM configuration is being saved on the shared storage. Executed hosted engine sanity over all supported storage types (NFS, iSCSI, Gluster, FC) to check there are no regressions, all passed.

In addition, checked that the configuration exist in the shared storage under /rhev/data-center/pool/HE-SD/conf-img/

The following files are saved there:
vm.conf, version, fhanswers.conf, hosted-engine.conf, broker.conf


Tested using:

vdsm-jsonrpc-4.17.18-0.el7ev.noarch
vdsm-python-4.17.18-0.el7ev.noarch
vdsm-hook-vmfex-dev-4.17.18-0.el7ev.noarch
vdsm-cli-4.17.18-0.el7ev.noarch
vdsm-yajsonrpc-4.17.18-0.el7ev.noarch
vdsm-xmlrpc-4.17.18-0.el7ev.noarch
vdsm-4.17.18-0.el7ev.noarch
vdsm-infra-4.17.18-0.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
libgovirt-0.3.3-1.el7_2.1.x86_64
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-host-deploy-1.4.1-1.el7ev.noarch
ovirt-setup-lib-1.0.1-1.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch

Comment 7 errata-xmlrpc 2016-03-09 18:52:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0375.html


Note You need to log in before you can comment on or make changes to this bug.