Bug 1167262 - [RFE][Tracker] Hosted-Engine: allow to deploy additional hosts from webadmin portal
Summary: [RFE][Tracker] Hosted-Engine: allow to deploy additional hosts from webadmin ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core
Version: 3.6.3
Hardware: Unspecified
OS: Unspecified
urgent
high vote
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Roy Golan
QA Contact: meital avital
URL:
Whiteboard:
: 1309568 (view as bug list)
Depends On: 1139793 1200469 1343147 1344900 1348103 1350423 1357615
Blocks: 1255230 Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2014-11-24 10:34 UTC by Sandro Bonazzola
Modified: 2016-08-14 11:53 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
You can now deploy or undeploy additional self-hosted engine hosts from the Administration Portal or using the REST API. Running 'hosted-engine --deploy' on additional self-hosted engine hosts is no longer required.
Clone Of:
Environment:
Last Closed: 2016-08-12 14:06:38 UTC
oVirt Team: SLA
rule-engine: ovirt-4.0.0+
ylavi: blocker+
mavital: testing_plan_complete-
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 42535 master ABANDONED Support deploying Hosted Engine components Never
oVirt gerrit 42536 master MERGED webadmin: Adding left panel to Add/Install host for HE 2016-05-30 12:33:46 UTC
oVirt gerrit 42537 master ABANDONED host-deploy: Support deploying Hosted Engine agent in AddVds Never
oVirt gerrit 43368 master MERGED core: Chage VM.isManaged () check Never
oVirt gerrit 43369 master MERGED core: Create a helper for hosted engine functions Never
oVirt gerrit 43562 master MERGED host-deploy: Support deploying Hosted Engine components 2016-05-29 19:34:38 UTC
oVirt gerrit 43564 master MERGED core: remove redundant lines Never
oVirt gerrit 43565 master MERGED restapi: Support host install/reinstall of HE 2016-05-30 11:07:56 UTC
oVirt gerrit 43809 master ABANDONED core: Adhere to project import order Never
oVirt gerrit 43830 master MERGED core: Add and expose a config value for the Hosted Engine VM name Never
oVirt gerrit 55920 master MERGED Add matrix parameter for deploy/undeploy hosted engine in host install 2016-05-31 10:08:24 UTC
oVirt gerrit 57855 master MERGED core: Avoid an infinite loop when untar an entry 2016-05-29 11:55:31 UTC
oVirt gerrit 58230 master MERGED core: Make the download size of HE config disk configurable 2016-05-30 10:37:45 UTC
oVirt gerrit 58261 ovirt-engine-4.0 MERGED host-deploy: Support deploying Hosted Engine components 2016-06-01 07:11:09 UTC
oVirt gerrit 58262 ovirt-engine-4.0 MERGED core: Make the download size of HE config disk configurable 2016-06-01 08:22:54 UTC
oVirt gerrit 58263 ovirt-engine-4.0 MERGED restapi: Support host install/reinstall of HE 2016-06-01 08:22:44 UTC
oVirt gerrit 58264 ovirt-engine-4.0 MERGED webadmin: Adding left panel to Add/Install host for HE 2016-06-01 08:22:36 UTC
oVirt gerrit 58343 ovirt-engine-4.0 MERGED core: Avoid an infinite loop when untar an entry 2016-06-01 07:11:05 UTC
Red Hat Bugzilla 1313903 None None None Never

Internal Links: 1313903

Description Sandro Bonazzola 2014-11-24 10:34:50 UTC
Tracking bug for allowing to deploy hosted engine additional hosts from webadmin portal

Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 10:58:46 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Doron Fediuck 2016-02-21 09:28:28 UTC
*** Bug 1309568 has been marked as a duplicate of this bug. ***

Comment 3 Red Hat Bugzilla Rules Engine 2016-02-21 09:32:01 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Sandro Bonazzola 2016-05-02 09:58:15 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 5 Yaniv Lavi 2016-05-23 13:19:12 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 6 Yaniv Lavi 2016-05-23 13:26:46 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 7 meital avital 2016-08-11 10:41:02 UTC
1336655, 1353600 - moved to ovirt-4.0.4

Comment 8 meital avital 2016-08-11 11:48:07 UTC
All 'Depends On' bug verified


Note You need to log in before you can comment on or make changes to this bug.