Bug 11602 - Routing table not being setup properly if IP aliases are present
Routing table not being setup properly if IP aliases are present
Status: CLOSED DUPLICATE of bug 11400
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-23 09:23 EDT by kevin_myer
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-23 09:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevin_myer 2000-05-23 09:23:57 EDT
I have run into a problem with the routing table not being created properly
if one or more IP aliases is present.  With an IP alias setup, if I reboot
the machine, two default routes are setup.  This causes problems because
the machine uses the last default route that is created, which ends up
being my secondary interface.  Any application that is set to listen to one
interface but not the other never sees packets destined for eth0:0.

If I rerun /etc/init.d/rc.d/network by hand and restart the network, the
second default route goes away, as does the host route to my aliases IP
address.  This is better than the above scenario but it seems the routing
setup is a bit broken with IP aliases present.

I've tested this on an older 5.2 box and everything works fine.
Comment 1 Bill Nottingham 2000-05-31 17:26:39 EDT

*** This bug has been marked as a duplicate of 11400 ***

Note You need to log in before you can comment on or make changes to this bug.