Bug 11403 - RedHat 6.2 trashes Solaris8
RedHat 6.2 trashes Solaris8
Status: CLOSED DUPLICATE of bug 5539
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-13 19:08 EDT by Suhaib Siddiqi
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-15 13:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhaib Siddiqi 2000-05-13 19:08:44 EDT
I had Solaris8 installed on one IDE disk and RH 6.2 Linux on othe SCSI
disk.  Linux has its own swap partition of the disk it is installed
(i.e.SCSI disk).

Each time I boot into the SUCKER RedHat Linux 6.2, it will trash the
Solaris8, by swaping on the IDE disk where Solaris is installed.
Linux should have no business of trashing other Operatinbg Systems.
Even Solaris disk in not mounted and Linux owns absoluely no partition
space on the disk where Solaris is installed.

FOR NOW I am ordering all my departmental computers to trash Linux and move
to Solaris8.  This simply SUCKS when on Oerating System start destroying
othetr OS.
Comment 1 Jeff Johnson 2000-05-14 09:16:59 EDT
This isn't an nfs-util problem, I will change the component.

Using only solaris8 will work. Otherwise, edit /etc/fstab to change the
location of your swap partition to another partition. You will
also need to run mkswap to create a swap partition on the new, unused
partition, see the man page.
Comment 2 Jay Turner 2000-05-15 13:37:59 EDT
*** This bug has been marked as a duplicate of 5539 ***
Comment 3 Suhaib Siddiqi 2000-05-15 13:49:59 EDT
By the way, I did use Solaris8.
1) the Linux swap partition is on /dev/sda5

2) Solaris 8 installed on /dev/hdb

3) there is no mention (ABSOLUTELY NO MENTION) of /dev/hdb any where
in /etc/fstab, so LINUX should have no buiness of trashing anything is not told
to touch.  THIS SIMPLY EITHER BAD PROGRAMMING, BAD DESIGN OR BAD PRACTICE OF
FORCING YOUR OPERATING TO TRASH OTHERS.

4) I DID delete /dev/sda5 swap from /etc/fstab, I saw that in DejaNews and in
warnings from Sun about RedHat 6.1 (but not 6.2)  BUTRH 6.2 when booted into,
will trash the Solaris8.

5) It seems the problem is more chrnoic then then what is reported in your bug
#5539 for RH 6.1.  The RH 6.2 will trash Solaris8 no matter what, delete swap
or not, remove swap mounts from /etc/fstab or not.  It is after destroying
other OS and data.

BTW: I am in-charge of IT at Inspire and would rather stay with Solaris then
use an OS which tends to destroy data and other OS without even warnings.

Note You need to log in before you can comment on or make changes to this bug.