Bug 5539 - Disk Druid did not allow the forcing not to use swap partition
Disk Druid did not allow the forcing not to use swap partition
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 10532 11403 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 19:43 EDT by rnelson
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 12:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rnelson 1999-10-04 19:43:13 EDT
I just did a new installation of Red Hat 6.1.  While running
through the install on my laptop (new install over 6.0)
using the cute new GUI, I found that Disk Druid grabbed what
it thought was a swap partition and allocated it.

However, that happened to be my Solaris X86 install.  It was
happily clobbered during my next reboot.  Perhaps not the
ideal solution.  I tried, but was not able to figure a way
to specify that the partition was not to be used.  Any text
I entered would be replaced with <swap>.

IIRC, Previous versions allowed me to clear the mount point
and the partition would not be used.

Ron
Comment 1 Gene Czarcinski 1999-10-05 20:30:59 EDT
This is a major problem (wiping out the Solaris partition!

The swap options seem to be a big problem in general in that Disk
Druid does not really allow you to select which swap partitions are to
be used.

------- Additional Comments From   10/11/99 06:51 -------
A related problem with disk druid is:
The RH6.1 graphical installation does noe allow you to install
without a swap partition at all (one may prefer to use a swapfile,
or no swap at all, since enough RAM is available [512MB])
The only way to install RH6.1 without a swap partition is text-mode
only install.
Comment 2 Jay Turner 1999-10-20 12:40:59 EDT
This issue has been assigned to a developer for further action.
Comment 3 Jay Turner 1999-10-22 09:52:59 EDT
*** Bug 6130 has been marked as a duplicate of this bug. ***

The X-Window Disk Druid has a few problems:

1) It doesn't recognise Solaris partitions.  Naughty!
It sees them as Linux Swap which is fair enough given that
they have the same partition id, but then there is no way
to change the mount point from <swap> to <not set>.  I don't
want to overwrite Solaris data with Linux swap.  The current
workaround is to use a partition manager to fake the id of
the solaris partition as something else during the Linux
installation.

2) The installer refuses to show a Next button until a
swap partition is defined.  I don't want one since I have
128M RAM.  I use Solaris x86 fine without a swap partition!

3) I can't define a root "/" partition greater than 1882M.
Why not?  It just complains "root partition too big".


------- Additional Comments From jturner@redhat.com  10/20/99 10:54 -------
We were hoping that we had fixed problem #1, but apparently we did
not.  Sorry about that . . . we will put it in the list for next
release.

You should be able to install in expert mode (type "expert" at the
boot prompt) and that should allow you to get past the requirement of
having a swap partition.  The other option is to create a 1M swap
partition and just delete it after you reboot the machine (remember to
remove it from /etc/fstab as well)

Problem #3 is a confusing situation, but what is really happening is
that the installer is trying to tell you that the BIOS on your
computer will not allow booting from a partition which is not within
the first 1024 sectors of the drive.  The best way to get around this
it to create a small (16-32M) /boot partition and then create your
root partition.  With this setup, the installer will let you create as
large a root partition as your drives will handle.
Comment 4 Jay Turner 2000-04-24 09:36:59 EDT
*** Bug 10532 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2000-05-15 13:37:59 EDT
*** Bug 11403 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.