Bug 1140451 - The gvfs-gdu-volume-monitor process was aborted during system shutdown
Summary: The gvfs-gdu-volume-monitor process was aborted during system shutdown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1075802
TreeView+ depends on / blocked
 
Reported: 2014-09-11 02:47 UTC by kyoneyama
Modified: 2018-12-09 18:32 UTC (History)
3 users (show)

Fixed In Version: gvfs-1.4.3-20.el6
Doc Type: Bug Fix
Doc Text:
Cause: GVfs doesn't check returned value when getting pool of GDU devices. This operation fails in some cases (e.g. during shutdown). Consequence: GDU Volume Monitor process is aborted if error occurs. Fix: GDU Volume Monitor now checks returned value. Result: GDU Volume Monitor doesn't abort.
Clone Of:
Environment:
Last Closed: 2015-02-19 12:27:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0237 normal SHIPPED_LIVE gvfs bug fix update 2015-02-19 17:26:34 UTC
GNOME Bugzilla 651824 None None None Never

Description kyoneyama 2014-09-11 02:47:50 UTC
Description of problem:

  The gvfs-gdu-volume-monitor process was aborted during system shutdown.
  The cause of abort is that it did not meet the g_assert() conditions.

  (gdb) bt
  #0  0x00000030f8432925 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
  #1  0x00000030f8434105 in abort () at abort.c:92
  #2  0x00000030f9c661c4 in g_assertion_message (domain=<value optimized out>, file=<value optimized out>, line=<value optimized out>, 
    func=0x3102c2d690 "gdu_pool_get_presentables", message=0x9582c0 "assertion failed: (pool != NULL)") at gtestutils.c:1358
  #3  0x00000030f9c66790 in g_assertion_message_expr (domain=0x3102c2a224 "libgdu", file=0x3102c2c545 "gdu-pool.c", line=2565, 
    func=0x3102c2d690 "gdu_pool_get_presentables", expr=<value optimized out>) at gtestutils.c:1369

  (gdb) l
  2560	 **/
  2561	GList *
  2562	gdu_pool_get_presentables (GduPool *pool)
  2563	{
  2564	        GList *ret;
  2565	        g_assert (pool != NULL);


Version-Release number of selected component (if applicable):

  - kernel-2.6.32-431.el6.x86_64
  - glibc-2.12-1.132.el6_5.2.x86_64
  - glib2-2.26.1-7.el6_5.x86_64
  - gvfs-1.4.3-16.el6_5.x86_64

How reproducible:

  No reproducer.

Steps to Reproduce:

  It occurred during the shutdown.
  The other reproducer is not known. 

Actual results:

  The process was aborted with a coredump.

Expected results:

  The process is completed correctly.

Additional info:

*  I assume that desktop processes were not completed correctly.

  -rw------- 1 root root 819200 2014-09-04 18:00:42.606894061 +0900 /core.17549

  Sep  4 18:00:39 TESTHOST abrtd: Got signal 15, exiting
  Sep  4 18:00:40 TESTHOST snmpd[2272]: Received TERM or STOP signal...  shutt
ing down...
  Sep  4 18:00:41 TESTHOST ntpd[40740]: ntpd exiting on signal 15
  Sep  4 18:00:41 TESTHOST init: Disconnected from system bus
  Sep  4 18:00:41 TESTHOST multipathd: mpath00d0: stop event checker thread (4
7049957472000)
  Sep  4 18:00:41 TESTHOST gnome-keyring-daemon[3287]: GVFS-RemoteVolumeMonito
r: Owner :1.47 of volume monitor org.gtk.Private.GduVolumeMonitor disconnected f
rom the bus; removing drives/volumes/mounts
  Sep  4 18:00:44 TESTHOST kernel: talpa-vfshook: Disabled


*  I found the similar cases:

  - Bug 609108
  - Bug 683315
  - Bug 713865

Comment 2 Ondrej Holy 2014-11-03 11:59:15 UTC
It also happens in different situations according the mentioned similar cases, not only during shutdown. The root cause are problems with dbus, unfortunately we haven't reliable reproducer. However we can handle those problems better to avoid crashes. There is upstream patch to do that:
https://bugzilla.gnome.org/show_bug.cgi?id=582579

Comment 6 errata-xmlrpc 2015-02-19 12:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0237.html


Note You need to log in before you can comment on or make changes to this bug.