Bug 1140674 - 'Recommendations' links are broken under 'Open Support Case' on Jboss ON
Summary: 'Recommendations' links are broken under 'Open Support Case' on Jboss ON
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Red Hat Access
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: CR02
: JON 3.3.0
Assignee: Spenser Shumaker
QA Contact: Jeeva Kandasamy
Jared MORGAN
URL:
Whiteboard:
Depends On:
Blocks: JON3-11 JON3-12
TreeView+ depends on / blocked
 
Reported: 2014-09-11 13:27 UTC by Jeeva Kandasamy
Modified: 2015-08-10 01:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The Red Hat Access server returns incomplete links to "recommendations" in some cases, which prevents the respective article from being displayed. To work around the issue, directly log into the https://access.redhat.com system with a web browser to see recommendations.
Clone Of:
Environment:
Last Closed: 2014-12-11 14:04:08 UTC
Type: Bug


Attachments (Terms of Use)
Recommendations-links-broken (106.89 KB, application/octet-stream)
2014-09-11 13:27 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-09-11 13:27:37 UTC
Created attachment 936547 [details]
Recommendations-links-broken

Description of problem:
'Recommendations' links are broken under 'Open Support Case' on Jboss ON

Version-Release number of selected component (if applicable):
JBoss Operations Network	
Version : 3.3.0.ER02
Build Number : 4fbb183:7da54e2
GWT Version : 2.5.0
SmartGWT Version : 3.0p

How reproducible:
always

Steps to Reproduce:
1. Login in to JBoss ON 3.3
2. Login in to 'Red hat Access'
3. Open new support case, enter all the details
4. You will get 'Recommendations' links on the right side, click any of the link.


Additional info: Screen shot is attached

Comment 3 Simeon Pinder 2014-09-29 08:12:49 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 7 Simeon Pinder 2014-10-21 20:24:27 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 8 Armine Hovsepyan 2014-10-22 12:59:15 UTC
issue is still visible in JON 3.3 ER05
screen-shot attached

Comment 10 Spenser Shumaker 2014-10-22 14:46:29 UTC
After further investigation this is a problem with how solutions are written.  This specific solution has relative URLs and not absolute URLs.  After examining other solutions its seems that most solutions use absolute URLs so this problem should not be common.  Should this bug be moved to the content team?

Comment 11 Libor Zoubek 2014-10-22 18:01:08 UTC
Maybe .. or can you detect if URL is absolute and prepend server address?

Comment 12 Spenser Shumaker 2014-10-22 19:05:56 UTC
I can open a bug for this but it be on the backlog and probably won't be prioritized for a few sprints.

Comment 15 Libor Zoubek 2014-10-29 08:55:10 UTC
this issue should be fixed with 0.9.36 tag which was pulled by this commit

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/c69f16666
time:    2014-10-29 09:27:44 +0100
commit:  c69f16666637b2e014da33f4f01864dbd413a003
author:  Libor Zoubek - lzoubek@redhat.com
message: update RHA to 0.9.36

Comment 16 Simeon Pinder 2014-11-03 19:03:39 UTC
Moving to ON_QA as available to test with latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=396547

Comment 17 Jeeva Kandasamy 2014-11-04 06:40:04 UTC
If we click any link under 'Recommendations' leads blank page.

Version:
JBoss Operations Network
Version : 3.3.0.CR01
Build Number : 08c2f39:6ac97ac
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Comment 18 Libor Zoubek 2014-11-04 12:15:48 UTC
There is an issue with this link:

"How do I install JBoss Enterprise Application Platform using yum or u2date?" -> "Red Hat Network"

This is because that link leads to page which then redirects to https and as we show it in IFRAME, browser does not like it and block it.

Other links should work.

Could you please verify, this issue with "Red Hat Network" link is gone, when you access to JON using https?

Comment 22 Jeeva Kandasamy 2014-11-07 07:32:55 UTC
I tested with https://hostname:7433. I'm seeing this issues with https also.

Browser: Firefox 31.0

Comment 25 Jared MORGAN 2014-11-17 01:41:30 UTC
Resetting to Red Hat Access component and setting RN flag so it sorts correctly in Release Notes. 

Is anything else required regarding docs, except for adding to Release Notes?


Note You need to log in before you can comment on or make changes to this bug.