Bug 1070437 (JON3-12) - Ability to create new support case from JBoss EAP 6 based server resource
Summary: Ability to create new support case from JBoss EAP 6 based server resource
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: JON3-12
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: CR01
: JON 3.3.1
Assignee: Jay Shaughnessy
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
: 1008030 (view as bug list)
Depends On: JON3-11 1134829 1140637 1140669 1140674 1144452 1144489 1144497
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-26 20:12 UTC by Heiko W. Rupp
Modified: 2015-09-03 00:02 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-27 19:58:24 UTC
Type: Enhancement


Attachments (Terms of Use)
fails qe (84.38 KB, image/png)
2014-07-31 18:12 UTC, Mike Foley
no flags Details
unable_to_attach_JDR_report (84.87 KB, image/png)
2015-01-29 14:44 UTC, Armine Hovsepyan
no flags Details
jon-new-case-jdr (131.81 KB, image/png)
2015-02-16 12:26 UTC, Armine Hovsepyan
no flags Details
eap_new_case_jdr (139.34 KB, image/png)
2015-02-16 12:27 UTC, Armine Hovsepyan
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JON3-12 Minor Verified Provide initial CSP integration for opening managed EAP cases 2016-06-17 18:31:17 UTC
Red Hat Bugzilla 1070323 None None None Never
Red Hat Bugzilla 1070431 None None None Never
Red Hat Bugzilla 1168373 None None None Never

Internal Links: 1070323 1070431 1168373

Description Heiko W. Rupp 2014-02-26 20:12:14 UTC
It must be possible to open a case for an EAP server that is managed by JON.
JON must pull the JDR data from the server and forward it to the CSP

Comment 1 JBoss JIRA Server 2014-06-26 15:20:49 UTC
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-12 to Resolved

Comment 2 Jirka Kremser 2014-06-26 15:29:15 UTC
It's in the master (3.3 will be based on it)

pull request #61
commits:
4012346e0
c49d37318
5a50fe270
63815b9e5
ce94b7c59
2eb8b5923
20d1821f3
1c2cea1c2
0979d143e
53cb140de
6876f8593
4eaddf84e
871942c5e

Comment 3 Simeon Pinder 2014-07-31 15:52:26 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 4 Mike Foley 2014-07-31 18:12:29 UTC
Created attachment 923015 [details]
fails qe

Comment 5 Mike Foley 2014-07-31 18:12:52 UTC
rha support is not built.  see attached.

Comment 6 JBoss JIRA Server 2014-08-15 22:51:33 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-12 to Reopened

Comment 7 JBoss JIRA Server 2014-08-20 07:40:04 UTC
Heiko Rupp <hrupp@redhat.com> updated the status of jira JON3-12 to Resolved

Comment 8 JBoss JIRA Server 2014-08-25 14:25:59 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-12 to Reopened

Comment 10 Jay Shaughnessy 2014-09-09 15:24:28 UTC
Mike, is this still an issue, has the feature been well defined for you? If so, please close or set MODIFIED for ER03.  If not please assign/work with Libor for ER03.

Comment 12 Mike Foley 2014-09-15 13:09:36 UTC
testing status as or ER02 ...

https://tcms.engineering.redhat.com/run/174522/

4 tests.  2 fail.  2 blocked.

Comment 13 Simeon Pinder 2014-09-17 02:49:18 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149

Comment 16 Simeon Pinder 2014-09-29 08:12:47 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 17 Mike Foley 2014-10-10 14:37:05 UTC
Documenting JON3-12 test results in JON 3.3 ER04


TCMS testcase run  https://tcms.engineering.redhat.com/run/185016/

Blocking BZ (also blocking for JON3-11) 
https://bugzilla.redhat.com/show_bug.cgi?id=1140669


JON 3-11 and JON 3-12 are failed QE in ER04.

Comment 19 Heiko W. Rupp 2014-10-13 07:52:07 UTC
*** Bug 1008030 has been marked as a duplicate of this bug. ***

Comment 21 Simeon Pinder 2014-11-03 19:03:37 UTC
Moving to ON_QA as available to test with latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=396547

Comment 23 JBoss JIRA Server 2014-11-05 12:04:38 UTC
mfoley user <mfoley@redhat.com> updated the status of jira JON3-12 to Resolved

Comment 24 Larry O'Leary 2015-01-06 00:49:10 UTC
Removing "Tracker" from title as this is not a tracker. Instead, this is an actual requirement that was submitted and partially implemented for JBoss ON 3.3.

As QE indicated that testing was incomplete at the time of GA, they had moved this to an invalid state. Moving back to ON_QA for 3.3.z for proper testing and validation.

Comment 25 Armine Hovsepyan 2015-01-29 14:44:23 UTC
Created attachment 985636 [details]
unable_to_attach_JDR_report

Comment 26 Armine Hovsepyan 2015-01-29 14:45:18 UTC
reassigned back
unable to attach jdr report with qa@redhat.com

Comment 27 Libor Zoubek 2015-01-29 16:40:00 UTC
below commit fixes possible caching issue of custom-cases.js which might have resulted in Invalid User/Pass when attempting to generate & attach JDR report.

branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/22a1dad19
time:    2015-01-29 17:36:35 +0100
commit:  22a1dad1933a25bf3b4731873a663760a3436671
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1160191 - Able to create New support case in JBoss ON who does not
         have
         'Manage Support Cases' permission
         Updated RHA to 0.9.73. All files changed since 3.3.0.GA had to
         be renamed
         (prevent browser caching) added CacheFilter class which sets
         correct headers to returned js,css,html files - so we don't
         need to rename files with further updates.

Comment 29 Simeon Pinder 2015-02-16 04:49:35 UTC
Moving to ON_QA as available to test with latest CP build:
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/16/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
*Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of jon-server-3.3.0.GA-update-01.zip.

Comment 30 Armine Hovsepyan 2015-02-16 12:26:00 UTC
Created attachment 992159 [details]
jon-new-case-jdr

Comment 31 Armine Hovsepyan 2015-02-16 12:27:45 UTC
Created attachment 992161 [details]
eap_new_case_jdr

Comment 32 Armine Hovsepyan 2015-02-16 12:28:19 UTC
verified in JON 3.3.1 CR1
screen-shots of cases containing JDR reports attached

Comment 33 Armine Hovsepyan 2015-02-16 13:09:05 UTC
BZ depends on JON3-11 and 1168373,  moving back to ON_QA until those 2 are verified/closed

Comment 34 Filip Brychta 2015-02-17 18:27:35 UTC
Moving back to verified. No longer depends On: 1168373. JON3-11 is verified.


Note You need to log in before you can comment on or make changes to this bug.