Bug 114104 - .xml extension in the live item URL is ignored
Summary: .xml extension in the live item URL is ignored
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Scott Seago
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
: 115015 (view as bug list)
Depends On:
Blocks: 113496
TreeView+ depends on / blocked
 
Reported: 2004-01-22 17:29 UTC by Alan Pevec
Modified: 2007-04-18 17:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 22:54:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Pevec 2004-01-22 17:29:12 UTC
Description of problem:
In APLAWS 5.2 CMS when you use .xml extension at the end of live item
URL, XML output is produced.

With the current CMS tip (as of 2004-01-22) this is just ignored, i.e.
output is HTML rendered, the same as without extension.


How reproducible:
Always

Steps to Reproduce:
1. Access the live item URL e.g.
http://localhost:9010/ccm/content/test-article.jsp
2. Change extension to .xml:
http://localhost:9010/ccm/content/test-article.xml

    

Actual Results:  The output is the same, HTML in both cases.

Expected Results:  test-article.xml should produce XML output of an
content item.

Additional info:

This functionality is needed for APLAWS+

Comment 1 Scott Seago 2004-02-05 16:52:07 UTC
*** Bug 115015 has been marked as a duplicate of this bug. ***

Comment 2 Scott Seago 2004-02-05 21:30:22 UTC
The infrastructure for doing this is still in place -- but the
relevant sections from the no-longer-used ItemDispatcher which strip
".xml" from the URL and set the "xmlMode" request attribute were never
added to ContentSectionServlet.

Fixed @40121

Comment 3 Jon Orris 2004-02-10 22:54:07 UTC
verified


Note You need to log in before you can comment on or make changes to this bug.