Bug 115015 - New content item dispatcher doesn't support '.xml' suffix on contnet items
New content item dispatcher doesn't support '.xml' suffix on contnet items
Status: CLOSED DUPLICATE of bug 114104
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Scott Seago
Jon Orris
Depends On:
  Show dependency treegraph
Reported: 2004-02-05 11:01 EST by Daniel Berrange
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2004-02-05 11:01:49 EST
Description of problem:
In 5.2 and prior, if you changed the filename extension used to refer
to a content item from '.jsp' to '.xml' then it would output the XML
representation of the content item instead of HTML. NB, this is not
the same as '?output=xml' because the former only output XML for the
item itself, where as the lkatter includes XML for the Bebop page and
all navigation elements.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Scott Seago 2004-02-05 11:25:08 EST
Hmm. How should this interact with the ML changes. Among other things,
on 6.0 and later, the ".jsp" is now optional. So for an article foo
with English and Spanish versions, the following URLs are valid:
foo.jsp, foo -- return default language html
foo.en, foo.en.jsp, foo.jsp.en -- return english html
foo.es, foo.es.jsp, foo.jsp.es -- return spanish html

For ".xml", the following should be allowed:
foo.xml, foo.en.xml, and foo.es.xml

I'm not sure if we'll need to worry about other combinations.
Comment 2 Daniel Berrange 2004-02-05 11:37:05 EST
Wow, I didn't know ML had soooo many suffix varieties. Just the simple
example you describe would be sufficient I reckon.
Comment 3 Richard Li 2004-02-05 11:47:07 EST
is this the same as bug 114104?
Comment 4 Scott Seago 2004-02-05 11:52:05 EST
Yes, it does seem to be the same.

*** This bug has been marked as a duplicate of 114104 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:01:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.