Bug 114139 - vncserver service does not load appropriate profile
vncserver service does not load appropriate profile
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vnc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
:
Depends On:
Blocks: 189875 221830
  Show dependency treegraph
 
Reported: 2004-01-22 19:11 EST by Zach Gorman
Modified: 2013-04-30 19:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0034
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 15:07:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zach Gorman 2004-01-22 19:11:44 EST
Description of problem:
When starting vncserver automatically on boot 
using /etc/sysconfig/vncservers and the vncserver service, the users' 
profiles are not loaded. As a result, each vncserver session is run 
using root's profile instead.

Version-Release number of selected component (if applicable):
RHEL3 fully up2date as of 22 Jan 04

How reproducible:
Always

Steps to Reproduce:
1. edit /etc/sysconfig/vncservers to add a user:
VNCSERVERS="1:myusername"
2. run "service start vncserver"
3. log in to the vnc server, open a termainal and type env | grep 
PATH.   

Actual results:
Path is missing several entries, including /usr/local/bin

Expected results:
Complete, working path (the same path you would get if you did "su - 
username")


Additional info:
The problem is that the su command in /etc/init.d/vncserver doesn't 
specify the " - " option. Therefore, the user's profile is never 
loaded.

To fix, change:
"su ${USER} -c \"cd ~${USER} ...
to:
"su - ${USER} -c \"cd ~${USER} ...

This is similar to bug 100706 for RH9
Comment 5 Rainer Traut 2007-01-02 09:02:27 EST
The same applies to EL4:

initlog $INITLOG_ARGS -c \
            "runuser ${USER} -c \"cd ~${USER} && [ -f .vnc/passwd ] && vncserver
:${DISP} ${VNCUSERARGS}\""

should be:

      initlog $INITLOG_ARGS -c \
            "runuser -l ${USER} -c \"cd ~${USER} && [ -f .vnc/passwd ] &&
vncserver :${DISP} ${VNCUSERARGS}\""
Comment 12 Red Hat Bugzilla 2007-02-08 15:07:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0034.html

Note You need to log in before you can comment on or make changes to this bug.