Bug 1141707 - DeviceFactoryError: new size must of type Size
Summary: DeviceFactoryError: new size must of type Size
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:34a97f67f203d1af89fea9e70f2...
Depends On:
Blocks: F21BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-09-15 09:47 UTC by Igor Gnatenko
Modified: 2014-10-24 02:24 UTC (History)
9 users (show)

Fixed In Version: anaconda-21.48.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-11 06:53:49 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (740.51 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: anaconda.log (50.72 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: environ (459 bytes, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: lsblk_output (2.40 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: nmcli_dev_list (1.34 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: os_info (377 bytes, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: program.log (26.91 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: storage.log (381.85 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: syslog (120.64 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: ifcfg.log (2.08 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details
File: packaging.log (44.25 KB, text/plain)
2014-09-15 09:48 UTC, Igor Gnatenko
no flags Details

Description Igor Gnatenko 2014-09-15 09:47:58 UTC
Version-Release number of selected component:
anaconda-21.48.6-1

The following was filed automatically by anaconda:
anaconda 21.48.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 767, in configure
    raise(e)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1752, in _destroy_device
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 122, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1808, in on_remove_clicked
    self._destroy_device(device)
DeviceFactoryError: new size must of type Size

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-WS-21_A_T7-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.16.1-301.fc21.x86_64
product:        Fedora-Workstation
release:        Cannot get release name.
type:           anaconda
version:        21_Alpha_TC7

Comment 1 Igor Gnatenko 2014-09-15 09:48:04 UTC
Created attachment 937501 [details]
File: anaconda-tb

Comment 2 Igor Gnatenko 2014-09-15 09:48:06 UTC
Created attachment 937502 [details]
File: anaconda.log

Comment 3 Igor Gnatenko 2014-09-15 09:48:08 UTC
Created attachment 937503 [details]
File: environ

Comment 4 Igor Gnatenko 2014-09-15 09:48:09 UTC
Created attachment 937504 [details]
File: lsblk_output

Comment 5 Igor Gnatenko 2014-09-15 09:48:10 UTC
Created attachment 937505 [details]
File: nmcli_dev_list

Comment 6 Igor Gnatenko 2014-09-15 09:48:12 UTC
Created attachment 937506 [details]
File: os_info

Comment 7 Igor Gnatenko 2014-09-15 09:48:13 UTC
Created attachment 937507 [details]
File: program.log

Comment 8 Igor Gnatenko 2014-09-15 09:48:17 UTC
Created attachment 937508 [details]
File: storage.log

Comment 9 Igor Gnatenko 2014-09-15 09:48:19 UTC
Created attachment 937509 [details]
File: syslog

Comment 10 Igor Gnatenko 2014-09-15 09:48:20 UTC
Created attachment 937510 [details]
File: ifcfg.log

Comment 11 Igor Gnatenko 2014-09-15 09:48:22 UTC
Created attachment 937511 [details]
File: packaging.log

Comment 12 David Lehman 2014-09-18 20:48:44 UTC
Fixed on rawhide (will be in anaconda-22.6). I'll propose as a blocker for f21 before the week is over.

Comment 13 Kamil Páral 2014-09-24 17:18:22 UTC
Discussed in 2014-09-24 Blocker Review meeting [1]. Accepted as a blocker. This is a clear blocker violating the Beta criterion: "must be able to remove existing volumes." 

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-09-24/

Comment 14 Fedora Update System 2014-10-01 15:36:02 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21

Comment 15 Fedora Update System 2014-10-03 04:00:05 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2014-10-04 03:22:37 UTC
Package anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.8-1.fc21 python-blivet-0.61.3-1.fc21 pykickstart-1.99.60-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11977/pykickstart-1.99.60-2.fc21,python-blivet-0.61.3-1.fc21,anaconda-21.48.8-1.fc21
then log in and leave karma (feedback).

Comment 17 Adam Williamson 2014-10-08 16:42:36 UTC
Should be fixed in 21 Beta TC2, we can test there.

Comment 18 Fedora Update System 2014-10-11 06:53:49 UTC
anaconda-21.48.8-1.fc21, python-blivet-0.61.3-1.fc21, pykickstart-1.99.60-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Bruno Roberto Zanuzzo 2014-10-21 01:53:50 UTC
Another user experienced a similar problem:

Description: 
I have a hd with two partitions one with windows 7 and another clean to install fedora 21 workstation beta TC4. Was automatically created mount points on custom partition using free space, but when I deleted the /home occurred this problem;

Steps:
1. previous system installed;
2. boot (live-usb) fedora workstation beta tc4 for install with free space;
3. disk partition method custom and then select automatic creation of mount points (/boot, /home, / and swap)
4. delete /home (only)

Expect results: 
delete /home and follow the installation normally.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=LIVE rootfstype=ext4 ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.17.0-301.fc21.x86_64
other involved packages: python-blivet-0.61.5-1.fc21.noarch, anaconda-gui-21.48.10-1.fc21.x86_64
package:        anaconda-core-21.48.10-1.fc21.x86_64
packaging.log:  
product:        Fedora"
reason:         DeviceFactoryError: _removeDevice() got an unexpected keyword argument 'moddisk'
release:        Fedora release 21 (Twenty One)
version:        Fedora

Comment 20 Shawn Starr 2014-10-24 01:15:21 UTC
Another user experienced a similar problem:

Reinstalling laptop, I used fdisk to wipe my existing Linux partitions, then rebooted. Started Installation, did a automatic partition, attempted to shrink /home partition, it failed. Got error.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-21-x86_64 quiet ip=dhcp ks=ftp://172.18.2.7/fedora-x86_64.cfg
hashmarkername: anaconda
kernel:         3.17.1-302.fc21.x86_64
package:        anaconda-21.48.10-1
product:        Fedora"
reason:         DeviceFactoryError: _removeDevice() got an unexpected keyword argument 'moddisk'
release:        Cannot get release name.
version:        Fedora

Comment 21 Adam Williamson 2014-10-24 01:45:52 UTC
Bruno: Shawn: what you guys hit doesn't actually look like the same thing the initial report here is for (though libreport decided it was a dupe, for some reason). The initial traceback is:

DeviceFactoryError: new size must of type Size

You guys are hitting:

DeviceFactoryError: _removeDevice() got an unexpected keyword argument 

which does not seem to be the same thing. If you can reproduce this, can you please save the logs from /tmp - at least the anaconda-tb file, which has the actual traceback in it, and storage.log - and file a new bug with them attached? Thanks.

Comment 22 Adam Williamson 2014-10-24 02:24:47 UTC
The bug Shawn and Bruno hit is https://bugzilla.redhat.com/show_bug.cgi?id=1154050 , it should be fixed in Beta RC1.


Note You need to log in before you can comment on or make changes to this bug.