Bug 1154050 - Fedora 21 workstation beta TC3: _removeDevice() got an unexpected keyword argument 'moddisk'
Summary: Fedora 21 workstation beta TC3: _removeDevice() got an unexpected keyword arg...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: mulhern
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1156248 1156250 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-17 11:56 UTC by Ankur Sinha (FranciscoD)
Modified: 2015-06-23 16:03 UTC (History)
10 users (show)

Fixed In Version: python-blivet-0.61.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-23 16:03:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Ankur Sinha (FranciscoD) 2014-10-17 11:56:04 UTC
Description of problem:
I have a new system that came with UEFI, Windows and Ubuntu. There are 2 windows NTFS partitions and two Ubuntu partitions (/ and swap). I'm trying to delete the ubuntu partitions and set up a Fedora system with /, /boot/efi/, /home, and swap. I can't seem to do this. After I delete the ubuntu partitions and create a new / and /boot/efi, it doesn't let me create any new partitions - it keeys saying "_removeDevice() got an unexpected keyword argument 'moddisk'"

I don't know enough about UEFI to know if this is a UEFI restriction or an anaconda bug. If it is a UEFI restriction, a better error message would be helpful. (At the moment, the user has no idea what's wrong)

Version-Release number of selected component (if applicable):
anaconda-21.48.9-1.fc21.x86_64
python-blivet-0.61.4-1.fc21.noarch

How reproducible:
Always

Steps to Reproduce:
1. Delete two existing ubuntu partitions (/ and swap) and leave 2 windows NTFS partitions as they are
2. Try to create the following Fedora disk scheme: (/, /boot/efi/, /home, swap)
3.

Actual results:
Won't let you

Expected results:
Should probably let you do it.

Additional info:

Comment 1 Ankur Sinha (FranciscoD) 2014-10-17 14:35:10 UTC
Tried "TC4" from koji - still getting this one.

http://koji.fedoraproject.org/koji/taskinfo?taskID=7894392

Comment 2 Ankur Sinha (FranciscoD) 2014-10-17 14:49:54 UTC
I got the same error when using blivet-gui trying to work around the issues. Looks like a blivet issue. This is the traceback that I managed to collect:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/blivetgui/utils.py", line 862, in add_device
    blivet.partitioning.doPartitioning(self.storage)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 864, in doPartitioning
    storage.devicetree._removeDevice(partition, moddisk=False, force=True)
TypeError: _removeDevice() got an unexpected keyword argument 'moddisk

Comment 3 Brian Lane 2014-10-18 00:33:35 UTC
Looks like commit 
909b095624 is needed on f21-branch too.

Comment 4 Fedora Update System 2014-10-20 19:01:58 UTC
anaconda-21.48.11-1.fc21, python-blivet-0.61.6-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.6-1.fc21,anaconda-21.48.11-1.fc21

Comment 5 Fedora Update System 2014-10-21 17:25:57 UTC
Package anaconda-21.48.11-1.fc21, python-blivet-0.61.6-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.11-1.fc21 python-blivet-0.61.6-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13413/python-blivet-0.61.6-1.fc21,anaconda-21.48.11-1.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-10-23 14:15:09 UTC
anaconda-21.48.12-1.fc21, python-blivet-0.61.7-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.7-1.fc21,anaconda-21.48.12-1.fc21

Comment 7 Adam Williamson 2014-10-24 02:23:00 UTC
*** Bug 1156250 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2014-10-24 02:23:30 UTC
The fix for this should be in RC1 when it lands, please re-test with that and confirm. Thanks!

Comment 9 Brian Lane 2014-10-24 02:57:27 UTC
*** Bug 1156248 has been marked as a duplicate of this bug. ***

Comment 10 Ankur Sinha (FranciscoD) 2014-10-24 08:23:50 UTC
I couldn't reproduce the exactly environment, but this is what I tested -

1. fresh install with separate standard partitions
2. reinstall over this, first deleting swap (which seemed to throw up the error)

It went fine - no errors this time. Should be fixed. 

/me gives karma

Comment 11 Bruno Roberto Zanuzzo 2014-10-24 18:20:45 UTC
Also not reproduce this bug in exactly the same environment.

But I saw this bug in the beta TC4, now in beta RC1 works for me.

Comment 12 Bruno Roberto Zanuzzo 2014-10-25 01:42:47 UTC
I actually found a similar case on Beta RC1.

Using UEFI boot of live usb, "Booting in insecure mode" and considering the existence of another partition beyond that will be installed fedora (in my case ntfs), when you click to automatically create mount points, the following are not created: /boot/efi and /home, and then the message appears:

"Automatic partitioning failed." Details:
"You have not defined a root partition (/), Which is required for installation of Fedora to continue. In bootloader valid target device found. See below for detais. For UEFI installation, you must include an EFI System Partition on a GPT-formatted disk, mounted at /boot/efi"

Moreover, the logs: storage.log or anaconda.log were not created.

Comment 13 Adam Williamson 2014-10-25 13:52:03 UTC
That's nothing at all like this bug, which was a simple coding snafu. Please file it separately. Thanks!

the logs certainly must exist in /tmp...


Note You need to log in before you can comment on or make changes to this bug.