Bug 114184 - unable to extrat .tgz or tar.bz2 files within tmpfs on 2.4.9-e.35 kernel
Summary: unable to extrat .tgz or tar.bz2 files within tmpfs on 2.4.9-e.35 kernel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jim Paradis
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-23 18:48 UTC by Rackspace Bugzilla
Modified: 2013-08-06 01:03 UTC (History)
3 users (show)

Fixed In Version: 2.4.9-e.61
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-03 01:19:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy/paste of sessiosn on 7.3 and ES 2.1 systems showing this issue. (4.59 KB, text/plain)
2004-01-23 18:49 UTC, Rackspace Bugzilla
no flags Details

Description Rackspace Bugzilla 2004-01-23 18:48:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
One of our customers that uses tmpfs on his 7.2 and 7.3 servers are
able to extract and uncompress in one go tar archives that are
compressed with gzip or bzip2. 

On his new Red Hat Enterprise Linux 2.1 ES system, running all the
newest errata and 2.4.9-e.35 kernel this is not the case. They recieve
errors from both bzip2 and gzip about compressed data being read from
a terminal. I'm not 100% certain as to the cause, but can replicate
the issue on any ES 2.1 system and also replicate having no issues on
any 7.3 system. 

Version-Release number of selected component (if applicable):
2.4.9-e.35

How reproducible:
Always

Steps to Reproduce:
1. Edit the /etc/fstab and add line 
none             /tmp                    tmpfs   noexec          0 0
2. mount -a to mount /tmp as a tmpfs filesystem, 'mount' and 'df' will
confirm this.
3. attempt to run 'tar -zxf foobar.tgz' or 'tar -jxf foobar.tar.bz2'
or 'tar -xvf foobar.tar.gz'
    

Actual Results:  As taken from an ES 2.1 system with all errata

[root@es21 tmp]# tar -xzf foo.tgz 
gzip: compressed data not read from a terminal. Use -f to force
decompression.
For help, type: gzip -h
tar: Child returned status 1
tar: Error exit delayed from previous errors
[root@es21 tmp]# 
[root@es21 tmp]# tar -jxf foo.tar.bz2 
bzip2: I won't read compressed data from a terminal.
bzip2: For help, type: `bzip2 --help'.
tar: Child returned status 1
tar: Error exit delayed from previous errors
[root@es21 tmp]# 

Expected Results:  As taken from a 7.3 system with all errata 

[root@73 tmp]# tar -xzf foo.tgz
[root@73 tmp]# 
[root@73 tmp]# tar -xzf foo.tar.bz2
[root@73 tmp]# 

Additional info:

See attachment for copy/paste output showing this.

Comment 1 Rackspace Bugzilla 2004-01-23 18:49:55 UTC
Created attachment 97216 [details]
copy/paste of sessiosn on 7.3 and ES 2.1 systems showing this issue.

Comment 3 Jim Paradis 2005-12-03 01:19:49 UTC
This appears to be working in the latest RHEL2.1 update.



Note You need to log in before you can comment on or make changes to this bug.