Bug 114202 - Bad unable to install pc_keyb: controller jammed (0x19)
Bad unable to install pc_keyb: controller jammed (0x19)
Status: CLOSED DUPLICATE of bug 113928
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 17:59 EST by Bruce Gallemore
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Gallemore 2004-01-23 17:59:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When I try to install from the iso I see messages
pc_keyb: controller jammed (0x19)
keyboard is locked when I get to the first CD-Found screen
There may be other earlier messages but they go by too fast.  I have 
tried noprobe acpi=off skipddc lowres together and in various 
combinations always with the same results.

Computer is a new emachines M6807 laptop.  It contains lots of 
potential problems Broadcom 54g wireless, media card reader, DVD+-RW, 
and ATI 9600.

I will welcome instructions on how to gather a log or stop the screen.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot M6807 from iso disk1
2.Hit space to check disks keyboard will be locked
3.
    

Actual Results:  Nothing keyboard is locked

Expected Results:  Installation starts

Additional info:
Comment 1 Bruce Gallemore 2004-02-03 23:40:55 EST
I read on the list that someone else encountered the same problem and 
fixed it by hooking up a usb keyboard.  I tried this and it did not 
fix the problem.  I also found that the keyboard locks up when trying 
to install FreeBSD X86_64.  This might indicate something wrong in 
some very old Unix code...but then again it might not.
Comment 2 Chris Kloiber 2004-02-19 13:32:23 EST
Same thing happens to me with Red Hat Enterprise Linux AS 3/x86_64
Same hardware. 
Comment 3 Ricardo Dalto 2004-02-19 15:46:52 EST
The same happens to me. The USB Keyboard trick didn't work also. 
It happens with all other 4 distros I tried. Could it be a Hardware
issue ? 
Comment 4 Bruce Gallemore 2004-02-20 00:22:09 EST
USB keyboard did not work for me either.  I thought it was just 
because I bought a cheap one.  I am currently getting SuSE to load 
using Mike Larkins Alt-F2... trick.  I tried red hat 9 i386 and it 
worked fine.  I noticed that red hat 9 shows the 1394 being loaded 
just before the media check screen.  FC1 x86_64 does not show that 
screen.
Comment 5 Chris Kloiber 2004-02-24 16:53:44 EST
Found a possible workaround: boot the installer with:

boot: linux atkbd_set=3

(may also need it on kernel line of grub.conf, it's still installing)
See Bug# 116640. We found that it should work on rawhide (with 2.6
kernel) but I accidentally booted the Red Hat Enterprise Linux 3
AS/x86_64 media with it and the keyboard works during the install.
Comment 6 Bruce Gallemore 2004-02-27 15:49:55 EST
I tried atkbd_set=3 no luck.  Actually I tried using all values from 
0-4.  No luck.  All were done with acpi=off.  I even tried 
acpi=force.  All produced the same results.  I read on the list that 
the probelem is fixed in 2.6.3.  I am willing to try to build my own 
install with 2.6.3, if someone can send me a link on how to get it on 
my hard disk.  Remember the only thing I can boot from is the CD.
Comment 7 Ricardo Dalto 2004-02-27 16:00:16 EST
Well, I was able to progress two more screens on the install but then
it froze again. I didn't try anything else other than atkkb=3. ( but I
will ) 
are we all on the same type of hardware? Emachines Laptop M6807/05 ?

(Bruce, if you get to build your own, pls share directions ) 
Comment 8 Chris Kloiber 2004-03-04 16:35:28 EST
Well it does seem that whatever make my laptop work that once didn't
last with atkbd_set=3. Bummer.
Comment 9 Bruce Gallemore 2004-03-04 21:13:05 EST
Yes I have an Emachines M6807.  I tried Mandrake 9.2rc1 and it 
worked.  Gave the same error message but went on to install.  Did not 
recognize an NTFS partition and insisted on wiping the disk clean.  
That wont work for me, at least not yet.  There were some good 
directions on the list from Boszormenyi Zoltan.  I will be trying it 
as soon as I get the entire tree downloaded.  Will try not to hit the 
commit button 3 times this time.  Sorry
Comment 10 Ricardo Dalto 2004-03-05 19:14:15 EST
Well, I figure in the past 4 days that ANY 32-bit Linux will install
and work hapilly with the machine.
As of *any* 64-bit Linux won't.  That mandrake version 9.2rc1 , is
that the 64bit ?
Comment 11 Bruce Gallemore 2004-03-05 20:31:00 EST
Yes the Mandrake 9.2rc1 was the 64-bit

I actually got the keyboard to work using:
linux text askmethod acpi=off
the trouble is that the ftp and http installs do not work and I am 
not sure what to copy to a CD for "Fedora Core"

I tried burning the entire development/x86_64 tree to a dvd but it 
did not recognize it.
Comment 12 Ricardo Dalto 2004-03-06 09:25:09 EST
but why wont you download the Fedora Core 1 - 64BIT ISOS??   I only
use isos, a lot easier to burn on a cd. 
I am off to try to get MDK now with that line you describe above...
Comment 13 Ricardo Dalto 2004-03-12 06:55:39 EST
I got MDK 9.2 64bits working pretty well on my emachines. 
But did you get the wireless working?  I can't get it to work. 
Neither ndiswrapper or linuxant driverloader won't compile. 
Comment 14 Ricardo Dalto 2004-03-12 19:20:19 EST
hey bruce, i tried to reply to you but your ISP is blocking mine for
some reason.
other option is hotmail, rdcsec@hotmail.com 
( but hotmail seems to be down now )
Comment 15 Chris Kloiber 2004-03-22 22:16:57 EST
You can forget the broadcom wireless. ndiswrapper and driverloader
require the Windows driver (which is 32-bit only).

I haven't heard it mentioned here yet, but the machine can be
installed with FC1-x86_64 by having a USB keyboard and booting with
the options:

boot: linux pci=noacpi

Upside, it installs, via-rhine ethernet works. Downside, no pcmcia. 2D
graphics possible with 'vesa' driver at 1024x768. 

Upgrade to xorg-x11 packages from devel and use the 'radeon' driver at
1280x800.
Comment 16 Ernie Petrides 2004-03-29 21:57:08 EST

*** This bug has been marked as a duplicate of 113928 ***
Comment 17 Red Hat Bugzilla 2006-02-21 14:00:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.