Bug 116640 - (KEYBOARD)Keyboard not recognized
(KEYBOARD)Keyboard not recognized
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 117426 (view as bug list)
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-02-23 22:30 EST by Joe Pawlak
Modified: 2015-01-04 17:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 02:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Pawlak 2004-02-23 22:30:50 EST
Description of problem:
 At start of installation anaconda trys to recognize the keyboard on 
my notebook (EMachines M6805). I get the error message pc_keyb: 
controller jammed (0x19)

I also tried linux noprobe but once the screen comes up to test the 
media, I cannot procede because it does not recognize the 
keyboard/keyboard input.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Kloiber 2004-02-23 23:22:26 EST
Ditto (eMachines M6807). The machine cannot be installed as x86_64. 
32-bit kernels work fine.

Message changes on kernel 2.6/x86_64 to:

atkbd.c: Unknown key released (translated set 0, code 0x41 on
isa0060/serio0).
stkbd.c: Use 'setkeycodes 41 <keycode>' to make it known.
Comment 2 Neil Horman 2004-02-24 16:12:12 EST
Judging by the error code, it appears that without a user space
override (via setkeycodes), this error is occuring because the atkbd
module is not assigning the proper default scancode table to the
keyboard module (set 0 does not appear to exist in the module, as the
error indicates).  Anywho, installing with the added kernel command
line parameter atkbd_set=3 assigns the appropriate scancode/keycode
table to the module, and  allows the installer to continue.
Comment 3 Joe Pawlak 2004-02-24 19:46:13 EST
I tried the two fixes, but the problem still happens.

I also have error pc_keyb: controller jammed (0x15) and Keyboard 
failed self test.
Comment 4 Jeremy Katz 2004-02-24 22:59:58 EST
USB keyboards should be better now (added hid to the list of modules
for the installer), for the other part, it's a kernel bug.
Comment 5 Justin M. Forbes 2004-03-04 01:38:51 EST
*** Bug 117426 has been marked as a duplicate of this bug. ***
Comment 6 Logan Mabe 2004-03-09 09:45:56 EST
I also have EMachines M6805 and recieve the same error. Also tried 
fixes and no luck. I have a different version of Linux installed. Can 
I mount the disk and run a program to do the install? Or does the 
install have to be initiated from the actual boot autorun? Any other 
fix ideas?
Comment 7 Marty Shannon 2004-03-26 07:59:36 EST
Not clear to me from the bugzilla info, but just for the record, this
occurs in FC1 (yarrow) as well.  I also get (after the "pc_keyb:
failed self-test"):

pc_keyb: controller jammed (0x19)

twice in a row.  That's with using atkbd_set=3 or not.  The same
message appears again (twice in a row) just after the serial driver is
initialized.

Anything else we can try?
Comment 8 Marty Shannon 2004-07-14 16:26:34 EDT
Now, in FC3T1, (yes, that's a three) the keyboard is simply completely
unrecognized with the install boot kernel, and as a result is
completely ignored on the eMachines M6805.  No diagnostics at all.
Comment 9 Dave Jones 2004-12-07 01:40:13 EST
still a problem with the final FC3 release & updates ?
Comment 10 Dave Jones 2005-04-21 02:37:55 EDT
no response, assuming fixed.
Comment 11 Joe Pawlak 2005-04-21 08:27:04 EDT
Ya, you assume that. I've given up on your crappy distribution. Crappy you say? 
Yes, first reported: 2/23/2004, still not working 12/07/2004, still not working 
4/21/2005!

Just give up.

Note You need to log in before you can comment on or make changes to this bug.