Bug 11427 - php-imap support no longer functions in 3.0.16
php-imap support no longer functions in 3.0.16
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 11487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-15 20:02 EDT by Seth Vidal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 10:16:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2000-05-15 20:02:20 EDT
Imp uses php-imap for connecting to imap servers.

The php ver 3.0.15 has a broken imap support function w/imp.
So I upgraded to 3.0.16 from rawhide.
when 3.0.16-2 is put in place I check to see what modules are enabled w/i
php

by loading a webpage with just this string in it:
<?php phpinfo(); ?>

the imap line on this page disappears.
under 3.0.15 (or with just the 3.0.15 imap.so file in /usr/lib/apache)
there is an imap entry in the phpinfo table.


It is building and its installed but the module does not function. I
haven't seen any error directly from php about it but php can be quiet
about errors.


I have checked to make sure the support wasn't disabled in php3.ini - it
has not been disabled - the module is just not being loaded.
Comment 1 Seth Vidal 2000-05-16 09:33:59 EDT
When I compile php manually with imap support turned on via the --with-imap
configure parameter I get the following error from attempting to load the php
module into apache:

cannot load /etc/httpd/modules/libphp3.so into server:
/etc/httpd/modules/libphp3.so: undefined symbol: gss_mech_krb5


So possibly this is a problem with the kerberos includes in the imap server
(which I presume are there b/c of the kerberizing of pine in this latest
release)

I am using a stock redhat 6.2 system installed fresh just as a build machine.

-sv
Comment 2 Nalin Dahyabhai 2000-05-16 10:16:59 EDT
This looks like a linking bug.  PHP's IMAP module is built using a static
c-client library, which prevents the linker from automatically picking up and
adding the GSS-API libraries as a dependency.  This will be fixed in 3.0.16-5
in Raw Hide (ftp://ftp.redhat.com/pub/rawhide/).
Comment 3 Nalin Dahyabhai 2000-05-17 13:59:59 EDT
*** Bug 11487 has been marked as a duplicate of this bug. ***
Comment 4 Nalin Dahyabhai 2000-05-17 14:01:59 EDT
The PHP packages for 3.0.16-5 will be in http://people.redhat.com/nalin/test/
at least until the next refresh of Raw Hide.
Comment 5 Seth Vidal 2000-05-18 15:50:59 EDT
the php-3.0.16-5 spec file needs the following to make the mysql sections fully
work if you define mysql 1

%if %{mysql}
%package mysql
Group: System Environment/Daemons
Prereq: php = %{version}
Summary: A Mysql database module for PHP3.
Prereq: /usr/bin/perl
Provides: php_database
Obsoletes: mod_php3-mysql
BuildPrereq: MySQL-devel

%description mysql
MySQL package for PHP access to a MySQL Database
%endif


thanks

Note You need to log in before you can comment on or make changes to this bug.