Bug 11487 - php-imap-3.0.15-2 cannot delete IMAP messages
Summary: php-imap-3.0.15-2 cannot delete IMAP messages
Status: CLOSED DUPLICATE of bug 11427
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL: http://faq.horde.org/cache/192.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-17 17:55 UTC by rbulling
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-17 17:59:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rbulling 2000-05-17 17:55:55 UTC
Using the stock php-imap-3.0.15-2 package from the Red Hat 6.2 Alpha
CD-ROM, I attempted to set up IMP, a web mail gateway package that uses
PHP3 to talk to an IMAP server. I used the RPMs horde-1.0.9-1, and
imp-2.0.9-1, available from http://www.horde.org/imp/. Although most
features of this package worked, it was impossible to delete messages.

The IMP faq describes a patch to php-3.0.15 that can fix this:
http://faq.horde.org/cache/192.html

It would be nice if Red Hat would release an updated php-imap-3.0.15-x
package with this patch, or alternately, if they would release a working
php-imap-3.0.16-x RPM. I tried using a Rawhide php-3.0.16-2.alpha.rpm and
php-imap-3.0.16-2.alpha.rpm package, but it appears that the IMAP module
does not actually get loaded into the PHP server. You can see whether the
IMAP module gets loaded by following these directions:
<http://faq.horde.org/cache/65.html>. I ran into the same problem when I
tried to roll my own php-3.0.16 RPM, so if the fix for this is to
just release a set of php-3.0.16 RPMS, you'll need to check whether the
IMAP module gets loaded, at least on the alpha architecture.

To get IMP to work and delete messages, I downgraded the PHP RPMs to
php-3.0.14-5 from one of the Rawhide distributions.

Comment 1 Nalin Dahyabhai 2000-05-17 17:59:59 UTC
The comments at http://faq.horde.org/cache/192.html indicate that this is fixed
in PHP 3.0.16.  Version 3.0.16-5 of the package fixes the problems with the imap
module not being loaded correctly (see bug #11427 for details on the problem).

*** This bug has been marked as a duplicate of 11427 ***


Note You need to log in before you can comment on or make changes to this bug.