Bug 114296 - Sylpheed cores when opening inbox
Sylpheed cores when opening inbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sylpheed (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Akira TAGOH
:
: 114298 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 07:31 EST by Andrew D Kirch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.9.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 07:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D Kirch 2004-01-26 07:31:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
This appears to be a sylpheed bug on x86-64 machines.  It appears to
not handle opening a large inbox (however it is looking for "libJIS".
 As to how large (or if any size at all is large) I don't know. 
Strace output (in full) is available upon request, and a 'locate'
output for libJIS.so is included at the bottom of the strace.  I have
duplicated this bug with FreshRPM's sylpheed rpm (recompiled from
src.rpm) and the tarball on good-day.

Version-Release number of selected component (if applicable):
sylpheed-0.9.8a-1.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Run sylpheed
2. download a reasonable amount of e-mail (a couple hundred messages)
3. open inbox
    

Actual Results:  Sylpheed Segfaults

Expected Results:  Sylpheed should open the inbox displaying e-mail.

Additional info:

open("/usr/lib64/gconv/tls/x86_64/libJIS.so", O_RDONLY) = -1 ENOENT
(No such file or directory)
stat("/usr/lib64/gconv/tls/x86_64", 0x7fbfff8630) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/gconv/tls/libJIS.so", O_RDONLY) = -1 ENOENT (No such
file or directory)
stat("/usr/lib64/gconv/tls", 0x7fbfff8630) = -1 ENOENT (No such file
or directory)
open("/usr/lib64/gconv/x86_64/libJIS.so", O_RDONLY) = -1 ENOENT (No
such file or directory)
stat("/usr/lib64/gconv/x86_64", 0x7fbfff8630) = -1 ENOENT (No such
file or directory)
open("/usr/lib64/gconv/libJIS.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\n\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=99192, ...}) = 0
mmap(NULL, 1146024, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a98f94000
mprotect(0x2a98fac000, 1047720, PROT_NONE) = 0
mmap(0x2a99094000, 98304, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a99094000
close(10)                               = 0
open("/usr/lib64/gconv/libGB.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\n\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=65856, ...}) = 0
mmap(NULL, 1112688, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a990ac000
mprotect(0x2a990bc000, 1047152, PROT_NONE) = 0
mmap(0x2a991ac000, 65536, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a991ac000
close(10)                               = 0
open("/usr/lib64/gconv/libCNS.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\16\0\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=465728, ...}) = 0
mmap(NULL, 1512560, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a991bc000
mprotect(0x2a9922e000, 1045616, PROT_NONE) = 0
mmap(0x2a992bc000, 466944, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 10, 0) = 0x2a992bc000
close(10)                               = 0
open("/usr/lib64/gconv/libKSC.so", O_RDONLY) = 10
read(10, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\200\t\0"...,
640) = 640
fstat(10, {st_mode=S_IFREG|0755, st_size=45256, ...}) = 0
mmap(NULL, 1092088, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x2a9932e000
mprotect(0x2a99339000, 1047032, PROT_NONE) = 0
mmap(0x2a9942e000, 45056, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0) = 0x2a9942e000
close(10)                               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

[trelane@localhost trelane]$ locate libJIS.so
/usr/lib/gconv/libJIS.so
/usr/lib64/gconv/libJIS.so
Comment 1 Andrew D Kirch 2004-01-26 07:43:01 EST
*** Bug 114298 has been marked as a duplicate of this bug. ***
Comment 2 Akira TAGOH 2004-01-28 00:23:32 EST
Why do you consider this problem related libJIS? could you give me the
backtrace on gdb?
If it's in gconv's modules, I wonder if the reason is large inbox. I
suspect there are the invalid encoding e-mail in your inbox.
Comment 3 Akira TAGOH 2004-01-28 00:24:56 EST
Plus, are you sure this problem doesn't appear on i386 (with same
Mailbox)? and this problem is x86-64 specific?
Comment 4 Andrew D Kirch 2004-01-29 02:23:17 EST
This inbox opened corrrectly in sylpheed in i386.  my suspicion
regarding libJIS is unfounded after rereading the backtrace since it
appears to have finally found the file after all.

Program received signal SIGSEGV, Segmentation fault.
0x0000002a9651bdf7 in __gconv_transform_internal_utf8 () from
/lib64/tls/libc.so.6


Looks like it might be a translation issue with UTF8, odd as I filter
all of APNIC and KRNIC.
Comment 5 Akira TAGOH 2004-01-30 05:14:06 EST
Ok, let me test sylpheed on x86-64 then. but I wonder if all e-mails
causes this problem. probably I will need your help to find an actual
problem. So could you please try to find which e-mails causes this
problem? I'm assuming you could use sylpheed without any problems
before, according to mentioning large inbox, no?
Comment 6 Akira TAGOH 2004-02-16 04:22:47 EST
Please try 0.9.9-1. it works fine to me.
Comment 7 Akira TAGOH 2004-09-02 07:04:26 EDT
no reply for a while. close this then. please repoen if this problem
still appears.

Note You need to log in before you can comment on or make changes to this bug.