Bug 114305 - Cannot convert string "fixed" to type FontStruct
Cannot convert string "fixed" to type FontStruct
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nedit (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-01-26 09:47 EST by Roger Nunn
Modified: 2013-07-02 18:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 10:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Nunn 2004-01-26 09:47:32 EST
Description of problem:


Version-Release number of selected component (if applicable):
nedit-5.3-4

How reproducible:
Always

Steps to Reproduce:
 
 launching nedit over ssh.
ssh from a Red Hat Linux 9 system to a Red Hat Enterprise Linux AS 3
system and run nedit.
The following error messages are logged in the background nedit fails
to function correctly (there is no way to select a file without the
extra font errors occuring regardless of font selection in the
preferences/default settings tab:

$ nedit
Cannot convert string "fixed" to type FontStruct


 Name: Text
    Class: XmTextField
    Character '\162' not supported in font.  Discarded.
 
 
    Name: Text
    Class: XmTextField
    Character '\143' not supported in font.  Discarded.


  


Additional info:
After further investigation:
error message is given in line 4226/4233 approx of nedit source:
preferences.c                                                        
                       
This points to the Motif XMText widget library
called in the beginning of the code as:
Xm/Text.h
                                                                     
          
This may simply refer to a missing fixed font alias or font or may be 
related to openmotif incompatibilities?
version info:
rh9 openmotif-2.2.2-14
RHEL AS 3 openmotif21-2.1.30-8 and openmotif-2.2.2-16


an ssh connection from the same RHL 9 to an RHEL AS2.1 machine and
then running nedit version nedit-5.1.1-10
with openmotif versions:
RHL 9 openmotif-2.2.2-14
RHEL AS2.1 openmotif version openmotif-2.1.30-11
shows no font errors and works fine.

also selecting the same 'known good' font that this nedit session is
using for the previous rhl to rhel3 connection using the command:
nedit -font '-adobe-courier-medium-r-normal--12-*-*-*' 
does not prevent the font errors.
Comment 1 Tim Waugh 2004-01-26 09:52:01 EST
See bug #73419.
Comment 2 Thomas Woerner 2004-03-17 06:18:16 EST
These problems will hopefully be fixed with the new openmotif version
2.2.3 that will be available soon.
Comment 3 Bastien Nocera 2004-03-22 10:35:11 EST
I recompiled your new version of openmotif on RHEL3.
The problem still exists, but on the same version of OpenMotif, on
FC2, the problem doesn't show up.

My test version of OpenMotif is there, I only changed the dependencies
(XFree86-devel, etc.):
http://people.redhat.com/bnocera/openmotif

To reproduce the problem, you just need to open the file chooser
(Ctrl+O) and watch the errors fly by.

I recompiled nedit with Tim's patch, bug #75189 and it works fine.
Updated nedit at the above URL as well.
Comment 9 Tim Waugh 2004-07-19 07:38:41 EDT
This requires further openmotif fixes as far as I can tell.
Comment 11 Tim Waugh 2004-08-19 11:20:11 EDT
Needs a new nedit package now.
Comment 13 Tim Waugh 2004-12-02 11:26:58 EST
Does nedit actually need any changes or does openmotif-2.2.3-3 fix everything?
Comment 14 Jindrich Novy 2005-04-21 10:12:11 EDT
I'm unable to reproduce this bug any more. Please reopen this bug if you still
see this issue.

Thanks,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.