Bug 114316 - sgi_fam conflicts with tcpwrappers
sgi_fam conflicts with tcpwrappers
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xinetd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 11:03 EST by Didier
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 23:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Didier 2004-01-26 11:03:58 EST
Description of problem:

When remotely opening an ssh shell from a client to an RHEL AS3 server
and launching a graphical application (e.g. gedit), gedit never
displays on the clients' desktop ; the server /var/log/messages shows
lots of :

Jan 26 16:57:57 dmbr063 xinetd[6342]: libwrap refused connection to
sgi_fam (libwrap=fam) from <no address>
Jan 26 16:57:58 dmbr063 xinetd[6350]: warning: can't get client
address: Transport endpoint is not connected


Version-Release number of selected component (if applicable):

xinetd-2.3.12-2.3E
fam-2.6.8-9

How reproducible:

Always


Steps to Reproduce:
1. % ssh remote_server
2. % gedit
3. wait
  
Actual results:

Nothing happens on the client side ; the server /var/log/messages is
swamped with errors (see above).

Expected results:

server gedit session should show up on client desktop.


Additional info:

- This looks like the same behaviour as bug #74696 ;
- adding "flags = NOLIBWRAP" to /etc/xinet.d/sgi_fam circumvents the
behaviour ;
- This behaviour only occurs on one of our three RHEL AS3 servers; all
servers have comparable /etc/hosts.* tcpwrappers settings.
Comment 1 William D. Hamblen 2004-01-26 11:44:18 EST
I am getting the same error messages on a fresh install of RHEL WS 3.0
(with patches) when I try to login at the GUI console login (Gnome,
KDE, and failsafe all do it).  The screen stays on the blue background
and the disk goes nuts as the error messages are sent many times per
second to /var/log/messages.

This is a slower machine (P3@600MHz with 512MB) so maybe a faster
system eventually gets the GUI started.  The only way I could login
though, was to put "fam: ALL" in tcp wrappers, or to stop xinetd
entirely, or to disable tcp wrappers.

This strikes me as an important bug to be fixed.  :-)
Comment 2 Didier 2004-01-30 03:10:25 EST
This also occurs on one of my FC1 boxes :
 tcp_wrappers-7.6-34.as21.1
 xinetd-2.3.12-4.10.0
 fam-2.6.8-12
Comment 3 W. Michael Petullo 2004-04-11 09:38:21 EDT
This is a duplicate of bug #108582.  This bug seems to be in Fedora
Core 1 Test 3, Fedora Core 1 and RHEL 3.  Can someone mark this as a
duplicate?
Comment 4 W. Michael Petullo 2004-04-11 09:42:14 EDT
I made a typing error in comment #3.  This bug is a duplicate of #108583.
Comment 5 Jay Turner 2004-09-01 23:12:58 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-315.html
Comment 6 Peter Bieringer 2006-02-06 09:36:12 EST
This issue isn't really fixed by the package provided in errata xinetd-2.3.12-6.3E

As described in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119918#c2
it is fixed since version xinetd-2.3.13-1. Would ever a backport or a minor
release update be supplied for RHEL3?

Note You need to log in before you can comment on or make changes to this bug.