Bug 114360 - Keyboard shortcuts missing "add" functionality
Keyboard shortcuts missing "add" functionality
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: control-center (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-27 04:37 EST by Otto J. Makela
Modified: 2013-04-02 00:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-27 10:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Otto J. Makela 2004-01-27 04:37:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The Preferences/Keyboard Shortcuts tool gnome-keybinding-properties
which is intended amongst other things for binding keyboard special
keys to events in the window manager seems to be completely missing
the "add" functionality described in the help system.

The process of adding special keys is described in the help system:
        Custom Shortcuts
        To add a hot key, perform the following steps:
        1. Click Add. A Custom Binding dialog is displayed.

Unfortunately there is nothing labeled "add" to click in the
gnome-keybinding-properties tool when I open it.


Version-Release number of selected component (if applicable):
control-center-2.2.0.1-9

How reproducible:
Always

Steps to Reproduce:
1.Select Preferences/Keyboard Shortcuts or run
/usr/bin/gnome-keybinding-properties
2.Note the complete lack of anything labeled "add"


Actual Results:  No "add" functionality though the help says there is,
and the tool has very little use without it.

Expected Results:  Reality conforming to claims made in the help file.


Additional info:
Comment 1 Jonathan Blandford 2004-01-27 10:25:56 EST
This was a patch that sun added, and never made it upstream.  It's
fixed in later versions of GNOME.
Comment 2 hawkeye parker 2004-01-27 18:16:52 EST
not sure how to do this properly, but cross-referencing:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88805
Comment 3 hawkeye parker 2004-01-27 18:22:19 EST
from http://oneguycoding.com/

-------

One of the things that's been bugging me about Gnome 2.2, or more 
specifically bluecurve in RedHat 9.0 is the inability to specify 
global keyboard shortcuts (aka hotkeys) for specific commands. For 
example, to open a gnome terminal session (or xterm, etc) I used to 
always set a shortcut keystroke of Ctrl-Alt-C (for console). Today, I 
finally figured out how to do this while browsing around in gconf-
editor, which is somewhat similar in functionality to the Windows 
Registry Editor, except the changes are stored in xml files under 
~/.gconf. 
Okay, here's a step by step method for setting keybindings in 
metacity in a gnome 2.2 environment, 

Run gconf-editor 
Open apps/metacity/global_keybindings 
Edit one of run_command_1 through run_command_12 and specify a 
keybinding to use to run that command (eg. "<Ctrl><Alt>c") 
Open apps/metacity/keybinding_commands 
Specify a command that you want to run after hitting the keybinding 
specified above (eg. gnome-terminal --geometry 90x40+50+50) 
Repeat as necessary
Comment 4 Bart Martens 2004-02-27 16:13:37 EST
Duplicate of bug #88805.

Note You need to log in before you can comment on or make changes to this bug.