Bug 88805 - Gnome/Preferences/Keyboard Shortcuts missing "Custom Shortcuts" entry
Summary: Gnome/Preferences/Keyboard Shortcuts missing "Custom Shortcuts" entry
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-center
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 88751 115295 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-14 12:37 UTC by Nathan Baker
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-09 19:06:59 UTC


Attachments (Terms of Use)

Description Nathan Baker 2003-04-14 12:37:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Hello --

I cannot seem to create custom shortcuts in the version of Gnome distributed
with RH 9; I could in RH 7.3.  Specifically, the Gnome Help Browser (Part I.
Using the Basic Preferences Tools -- Customizing Keyboard Shortcuts) indicates
that there should be a Custom Shortcuts entry in the Keyboard Shortcuts
preferences tool.  However, I only have the Text Editing Shortcut and Desktop
Shortcut items.

This system was upgraded from RedHat 7.3.

Thanks!

Version-Release number of selected component (if applicable):
gnome-desktop-2.2.0.1-4

How reproducible:
Always

Steps to Reproduce:
1.  Open Preferences->Keyboard Shortcuts
2.  Look ma, no "Custom Shortcuts"!
3.  Open Help -- apparently, the "Custom Shortcuts" should be in the Keyboard
Shortcuts preferences tool.
    

Actual Results:  Could customize shortcuts...

Expected Results:  Should have been able to customize shortcuts...

Additional info:

Just upgraded from RH 7.3

Comment 1 Havoc Pennington 2003-04-14 14:15:08 UTC
The docs are just wrong, because there was a Sun-specific patch that added 
that feature and someone documented it.

The custom keybindings do exist in RHL8 and RHL9, but you have to use 
gconf-editor or gconftool to set them for now.

Comment 2 hawkeye parker 2004-01-27 23:17:06 UTC
not sure how to do this properly, but cross-referencing:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114360

Comment 3 hawkeye parker 2004-01-27 23:21:55 UTC
from http://oneguycoding.com/

-------

One of the things that's been bugging me about Gnome 2.2, or more 
specifically bluecurve in RedHat 9.0 is the inability to specify 
global keyboard shortcuts (aka hotkeys) for specific commands. For 
example, to open a gnome terminal session (or xterm, etc) I used to 
always set a shortcut keystroke of Ctrl-Alt-C (for console). Today, I 
finally figured out how to do this while browsing around in gconf-
editor, which is somewhat similar in functionality to the Windows 
Registry Editor, except the changes are stored in xml files under 
~/.gconf. 
Okay, here's a step by step method for setting keybindings in 
metacity in a gnome 2.2 environment, 

Run gconf-editor 
Open apps/metacity/global_keybindings 
Edit one of run_command_1 through run_command_12 and specify a 
keybinding to use to run that command (eg. "<Ctrl><Alt>c") 
Open apps/metacity/keybinding_commands 
Specify a command that you want to run after hitting the keybinding 
specified above (eg. gnome-terminal --geometry 90x40+50+50) 
Repeat as necessary

Comment 4 Bart Martens 2004-02-27 21:15:21 UTC
This bug still exists in Fedora Core 1. See bug #115295. Is the
solution to modify the documentation?


Comment 5 Jef Spaleta 2004-02-27 22:21:15 UTC
*** Bug 115295 has been marked as a duplicate of this bug. ***

Comment 6 Marco Pesenti Gritti 2004-10-21 11:52:27 UTC
*** Bug 88751 has been marked as a duplicate of this bug. ***

Comment 7 Ray Strode [halfline] 2005-09-09 19:06:59 UTC
Hi Nathan and Bart,

Both Red Hat Linux 9 and Fedora Core 1 are presently unsupported.  Can you
reproduce this problem on a recent version of RHEL or Fedora Core?

If so, please feel free to reopen this bug report.


Note You need to log in before you can comment on or make changes to this bug.