Bug 1143947 - Removal of RecoveryHelpers fails silently if no scan is in progress
Summary: Removal of RecoveryHelpers fails silently if no scan is in progress
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager
Version: 6.2.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR12
: EAP 6.4.0
Assignee: Michael
QA Contact: Hayk Hovsepyan
URL:
Whiteboard:
: 1145513 (view as bug list)
Depends On: 1143956
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-18 10:04 UTC by Tom Ross
Modified: 2019-08-19 12:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In JBoss EAP 6 the Transaction Manager recovery operateraton queries resources for their view of in-doubt transaction branches. A "RecoveryHelper" which JCA registers helps to achieve this. When the resource is removed from the system the helper is de-registered. Previous versions of the product contained a race condition in the code whereby if the removal happened during a "recovery scan" then the helper was not removed. This resulted in the possibility that transaction recovery would continue using resources even though they a deployment had removed it from the server. The race condition has been removed in this release of JBoss EAP 6.
Clone Of:
: 1145513 (view as bug list)
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBTM-2241 Major Closed Removal of RecoveryHelpers fails silently if no scan is in progress 2015-10-02 17:30:50 UTC

Description Tom Ross 2014-09-18 10:04:41 UTC
There is some code in XARecoveryModule#removeXAResourceRecoveryHelper that defers removal of recovery helpers if a scan is in progress but skips the removal otherwise.

Comment 2 tom.jenkinson 2014-09-22 10:05:45 UTC
fixed in community version, await release

Comment 4 Ivo Studensky 2014-09-23 09:38:49 UTC
*** Bug 1145513 has been marked as a duplicate of this bug. ***

Comment 5 JBoss JIRA Server 2014-12-02 15:51:53 UTC
Tom Jenkinson <tom.jenkinson@redhat.com> updated the status of jira JBTM-2241 to Closed

Comment 6 tom.jenkinson 2014-12-05 12:41:31 UTC
Went into 4.17.23

Comment 7 Hayk Hovsepyan 2014-12-08 15:02:09 UTC
Verified on revision EAP 6.4.0.DR12

Now it always proceeds revcovery helper removal requests in XARecoveryModule#removeXAResourceRecoveryHelper.


Note You need to log in before you can comment on or make changes to this bug.