Bug 11442 - rpm-3.0.4-0.48 breaks purp-0.9.2-2 (Powertools-6.2)
rpm-3.0.4-0.48 breaks purp-0.9.2-2 (Powertools-6.2)
Status: CLOSED DUPLICATE of bug 11124
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-16 07:54 EDT by Jean Berthomieu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-20 06:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Berthomieu 2000-05-16 07:54:33 EDT
version 3.0.4 of rpm prevents "purp" from running on i386, sparc, ...
when purp is launched with an arg (path to RPMS), it dies with some message
stating that it could not load some shared library (module fdOpen).
After incriminating erroneously glibc, I could find it has to do with rpm.
Here is some dirty hack, until it is fixed :
Reinstalling old rpm from 6.1 dist.
- rpm -e rpm-build-3.0.4              # because of dependencies
- rpm -Uvh --force rpm-3.0.3-*.rpm    # from redhat-6.1
- rpm -Uvh --force rpm-python-3.0.4-*.rpm # that was overwriten by prev cmd

(don't know if I can reinstall rpm-build - which I don't need)

"purp" is the only tool I know that can upgrade a remote station thru a
text interface.
Comment 1 Chris Siebenmann 2000-05-20 06:06:59 EDT
RedHat has opted to change the RPM shared library ABI between
RPM 3.0.3 and RPM 3.0.4 without bothering to even increment the
shared library version number, so that there can be a visible
indication or warning of coming failures.

 Unfortunately, since they changed the API at the same time it's
not just a simple matter of recompiling the application.

 While RedHat is free to do this, I think it's a bit suboptimal
(among other things, it breaks RPM's dependancy checking!).
It should be possible to act like glibc and provide backwards
compatable interfaces (or even symbol versioning, perhaps).
Or simply avoid breaking the ABI and API in a minor version
change in a minor OS revision.
Comment 2 Jean Berthomieu 2000-07-04 09:39:22 EDT

*** This bug has been marked as a duplicate of 11124 ***
Comment 3 Jean Berthomieu 2000-07-04 09:48:48 EDT
If you reinstalled previous version of rpm (3.0.3), so that purp keeps running,
don't forget to reinstall now, current version (i.e. rpm-3.0.4) before running
new purp-0.9.5 ;-)

(ftp://ftp.lysator.liu.se/pub/unix/purp/purp-0.9.5/purp-0.9.5-1.i386.rpm)

Note You need to log in before you can comment on or make changes to this bug.