Bug 1144378 - IllegalStateException while uploading new package to repository after deleting existing packages
Summary: IllegalStateException while uploading new package to repository after deletin...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Content
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: JON 3.4.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-19 09:46 UTC by Armine Hovsepyan
Modified: 2019-05-16 10:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-16 10:40:00 UTC
Type: Bug


Attachments (Terms of Use)
illegal_state_exception (98.11 KB, application/octet-stream)
2014-09-19 09:46 UTC, Armine Hovsepyan
no flags Details
agent.log (504.94 KB, text/plain)
2014-09-19 09:50 UTC, Armine Hovsepyan
no flags Details
server.log (171.17 KB, text/plain)
2014-09-19 09:53 UTC, Armine Hovsepyan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1126044 None NEW Deployment content new war cannot be displayed 2019-05-20 14:09:08 UTC
Red Hat Bugzilla 1126460 None NEW deploying new app from subscription repo does nothing 2019-05-20 14:09:08 UTC

Internal Links: 1126044 1126460

Description Armine Hovsepyan 2014-09-19 09:46:23 UTC
Created attachment 939161 [details]
illegal_state_exception

Description of problem:
Illegal State Exception while uploading new package to repository after deleting existing packages

Version-Release number of selected component (if applicable):
JON 3.3 ER03

How reproducible:
always

Steps to Reproduce:
1. Install test.war to EAP standalone server using bundle deployment
2. Create a 'test' repository, upload new version of test.war and subscribe to test.war application
3. Navigate to 'test' repository, select uploaded package click delete package
4. Click Upload new package button, select a package and click upload button

Actual results:
After step 3. package is not removed
After step 4. illegal state exception on page

Expected results:
after step 3. Not sure if 'at least one' package should be left or not.
After step 4. new package is uploaded without errors on page

Additional info:
screen-shot attached
server and agent logs attached

Comment 1 Armine Hovsepyan 2014-09-19 09:50:44 UTC
Created attachment 939173 [details]
agent.log

Comment 2 Armine Hovsepyan 2014-09-19 09:53:48 UTC
Created attachment 939177 [details]
server.log

Comment 6 Filip Brychta 2019-05-16 10:40:00 UTC
I can't reproduce in JON 3.3.12.ER01. After step 3 it's correctly removed and after step 4 it's correctly added. Closing.


Note You need to log in before you can comment on or make changes to this bug.